<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.sentinelcolorado.com/xmlrpc.php" />
<meta property="og:image" content="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" />

<title>Man convicted of murder in Colorado woman&#039;s stabbing - Sentinel Colorado</title>
<link rel="canonical" href="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/" />
<link rel="publisher" href="https://plus.google.com/+AuroraSentinelNews" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man convicted of murder in Colorado woman&#039;s stabbing - Sentinel Colorado" />
<meta property="og:description" content="CASTLE ROCK |  Colorado prosecutors say a man who repeatedly stabbed a woman and then dumped her body alongside a highway has been found guilty of first-degree murder and is facing a lifetime prison sentence. Douglas County jurors on Friday also found 38-year-old Mihail Petrov guilty of seven other charges in the death of 24-year-old &hellip;" />
<meta property="og:url" content="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/" />
<meta property="og:site_name" content="Sentinel Colorado" />
<meta property="article:publisher" content="https://www.facebook.com/theaurorasentinel" />
<meta property="article:section" content="Metro" />
<meta property="article:published_time" content="2019-02-04T01:21:12+00:00" />
<meta property="fb:app_id" content="2092316581083652" />
<meta property="og:image" content="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" />
<meta property="og:image:secure_url" content="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" />
<meta property="og:image:width" content="440" />
<meta property="og:image:height" content="341" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="CASTLE ROCK |  Colorado prosecutors say a man who repeatedly stabbed a woman and then dumped her body alongside a highway has been found guilty of first-degree murder and is facing a lifetime prison sentence. Douglas County jurors on Friday also found 38-year-old Mihail Petrov guilty of seven other charges in the death of 24-year-old [&hellip;]" />
<meta name="twitter:title" content="Man convicted of murder in Colorado woman&#039;s stabbing - Sentinel Colorado" />
<meta name="twitter:site" content="@SentinelColo" />
<meta name="twitter:image" content="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" />
<meta name="twitter:creator" content="@SentinelColo" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://www.sentinelcolorado.com/","sameAs":["https://www.facebook.com/theaurorasentinel","https://instagram.com/SentinelColorado","https://plus.google.com/+AuroraSentinelNews","https://twitter.com/SentinelColo"],"@id":"https://www.sentinelcolorado.com/#organization","name":"Sentinel Colorado","logo":"https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/11110751/Sentinel-Flag-Email-Signature-V2.jpg"}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Feed" href="https://www.sentinelcolorado.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Comments Feed" href="https://www.sentinelcolorado.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Man convicted of murder in Colorado woman&#8217;s stabbing Comments Feed" href="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/feed/" />
<link rel='stylesheet' id='wphb-critical-css-css' href='https://www.sentinelcolorado.com/wp-content/plugins/wp-hummingbird/admin/assets/css/critical.css?ver=6f76e43ca7be939a13665c4f3c131794' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.sentinelcolorado.com/wp-includes/css/dist/block-library/style.min.css?ver=6f76e43ca7be939a13665c4f3c131794' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-email-subscribe-css' href='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/modules/shortcodes/css/jetpack-email-subscribe.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.sentinelcolorado.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=93bc67e89bc4998b79b2f1fa650def01' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.sentinelcolorado.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css' href='https://www.sentinelcolorado.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.9.5' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://www.sentinelcolorado.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.9.5' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://www.sentinelcolorado.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.9.5' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='td-theme-css' href='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/style.css?ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://www.sentinelcolorado.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=b374619cdb09c180dbf43dd944b44575' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/comment-reply.min.js?ver=6f76e43ca7be939a13665c4f3c131794'></script>
<link rel='https://api.w.org/' href='https://www.sentinelcolorado.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sentinelcolorado.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sentinelcolorado.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.sentinelcolorado.com/?p=340344' />
<link rel="alternate" type="application/json+oembed" href="https://www.sentinelcolorado.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sentinelcolorado.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F&#038;format=xml" />
<script type='text/javascript'>var tminusnow='{"now":"2\/3\/2019 18:34:20"}';</script><script type="text/javascript">(function(url){if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){return;}
var addEvent=function(evt,handler){if(window.addEventListener){document.addEventListener(evt,handler,false);}else if(window.attachEvent){document.attachEvent('on'+evt,handler);}};var removeEvent=function(evt,handler){if(window.removeEventListener){document.removeEventListener(evt,handler,false);}else if(window.detachEvent){document.detachEvent('on'+evt,handler);}};var evts='contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');var logHuman=function(){if(window.wfLogHumanRan){return;}
window.wfLogHumanRan=true;var wfscr=document.createElement('script');wfscr.type='text/javascript';wfscr.async=true;wfscr.src=url+'&r='+Math.random();(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);for(var i=0;i<evts.length;i++){removeEvent(evts[i],logHuman);}};for(var i=0;i<evts.length;i++){addEvent(evts[i],logHuman);}})('//www.sentinelcolorado.com/?wordfence_lh=1&hid=8114FB59EB03FC36A1068C04F1A875E2');</script><style type="text/css" id="ub_admin_bar_logo">body #wpadminbar #wp-admin-bar-wp-logo>.ab-item{background-image:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301002711/icon-sm.png);background-repeat:no-repeat;background-position:50%;background-size:80%}body #wpadminbar #wp-admin-bar-wp-logo>.ab-item .ab-icon:before{content:" "}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<script>window.tdwGlobal={"adminUrl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/","wpRestNonce":"f002a45f91","wpRestUrl":"https:\/\/www.sentinelcolorado.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://www.sentinelcolorado.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("https://www.sentinelcolorado.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='3533ac2d-0ef4-4198-a75a-b279b8fc0fd3';oneSignal_options['autoRegister']=true;oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['path']="https://www.sentinelcolorado.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";oneSignal_options['safari_web_id']="web.onesignal.auto.521cdcf4-43b8-4659-a2e2-fd037f95e0d5";oneSignal_options['promptOptions']={};oneSignal_options['notifyButton']={};oneSignal_options['notifyButton']['enable']=true;oneSignal_options['notifyButton']['position']='bottom-right';oneSignal_options['notifyButton']['theme']='default';oneSignal_options['notifyButton']['size']='small';oneSignal_options['notifyButton']['prenotify']=true;oneSignal_options['notifyButton']['displayPredicate']=function(){return OneSignal.isPushNotificationsEnabled().then(function(isPushEnabled){return!isPushEnabled;});};oneSignal_options['notifyButton']['showCredit']=true;OneSignal.init(window._oneSignalInitOptions);});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script>

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";var td_ajax_url="https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.0.1";var td_get_template_directory_uri="https:\/\/www.sentinelcolorado.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="10";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="1";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#c0223b";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>

<style>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</style>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-31800290-1','auto');ga('require','displayfeatures');ga('send','pageview');</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.sentinelcolorado.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.sentinelcolorado.com/category/orecent-headlines/",
                                "name": "0Recent Headlines"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/",
                                "name": "Man convicted of murder in Colorado woman&#8217;s stabbing"                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://cdn.sentinelcolorado.com/2018/03/06113526/cropped-SentinelFlag-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.sentinelcolorado.com/2018/03/06113526/cropped-SentinelFlag-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://cdn.sentinelcolorado.com/2018/03/06113526/cropped-SentinelFlag-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.sentinelcolorado.com/2018/03/06113526/cropped-SentinelFlag-270x270.png" />
<style type="text/css" id="wp-custom-css">.sf-menu ul .td-menu-item>a{font-size:15px;font-weight:bold}</style>

<style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#c0223b}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.sfHover>a,.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#c0223b}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a,.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#c0223b}.tdm-btn-style1{background-color:#c0223b}.tdm-btn-style2:before{border-color:#c0223b}.tdm-btn-style2{color:#c0223b}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #c0223b;-moz-box-shadow:0 2px 16px #c0223b;box-shadow:0 2px 16px #c0223b}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #c0223b;-moz-box-shadow:0 4px 26px #c0223b;box-shadow:0 4px 26px #c0223b}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#000}</style>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script>
<script>googletag.cmd.push(function(){googletag.defineSlot('/8540113/120x60_Search',[120,60],'div-gpt-ad-1520977200202-0').addService(googletag.pubads());googletag.defineSlot('/8540113/468x60_Footer',[[728,90],[468,60],[960,90]],'div-gpt-ad-1520977200202-1').addService(googletag.pubads());googletag.defineSlot('/8540113/468x60_ROS',[468,60],'div-gpt-ad-1520977200202-2').addService(googletag.pubads());googletag.defineSlot('/8540113/960x90_ROS',[[728,90],[960,90]],'div-gpt-ad-1520977200202-3').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_1',[300,250],'div-gpt-ad-1520977200202-4').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_2',[300,250],'div-gpt-ad-1520977200202-5').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_3',[300,250],'div-gpt-ad-1520977200202-6').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_4',[300,250],'div-gpt-ad-1520977200202-7').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_1',[300,40],'div-gpt-ad-1520977200202-8').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_2',[300,40],'div-gpt-ad-1520977200202-9').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_3',[300,40],'div-gpt-ad-1520977200202-10').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_4',[300,40],'div-gpt-ad-1520977200202-11').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_5',[300,40],'div-gpt-ad-1520977200202-12').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_06',[300,250],'div-gpt-ad-1535473829598-0').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_07',[300,250],'div-gpt-ad-1535473909054-0').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_08',[300,250],'div-gpt-ad-1535473946235-0').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_09',[300,250],'div-gpt-ad-1535473987639-0').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_10',[300,250],'div-gpt-ad-1535474037435-0').addService(googletag.pubads());googletag.defineSlot('\/8540113\/AS_300x250_Right_5',[300.0,250.0],'div-gpt-ad-1528827699928-0').addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.enableServices();});</script>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-340344 single-format-standard man-convicted-of-murder-in-colorado-womans-stabbing global-block-template-11 single_template_5 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SentinelColo" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-primary-container"><ul id="menu-primary" class="td-mobile-main-menu"><li id="menu-item-264972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first menu-item-264972"><a href="https://www.sentinelcolorado.com/metro/">Metro<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-264971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264971"><a href="https://www.sentinelcolorado.com/metro/nation-and-world/">Colorado, Nation &#038; World</a></li>
<li id="menu-item-264961" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264961"><a href="https://www.sentinelcolorado.com/sentinel-biz/">Sentinel Biz</a></li>
<li id="menu-item-336101" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-336101"><a href="https://www.sentinelcolorado.com/obituaries/">Obituaries</a></li>
<li id="menu-item-264968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264968"><a href="https://www.sentinelcolorado.com/metro/your-news/">Your News</a></li>
</ul>
</li>
<li id="menu-item-265088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-265088"><a href="https://www.sentinelcolorado.com/opinion/">Opinion</a></li>
<li id="menu-item-264966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-264966"><a href="https://www.sentinelcolorado.com/sentinel-magazine/">The Magazine<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-264978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264978"><a href="https://www.sentinelcolorado.com/colorado-table/">Colorado Table</a></li>
</ul>
</li>
<li id="menu-item-336042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-336042"><a href="https://www.sentinelcolorado.com/sentinel-colorado-events-page/">Sentinel Events Calendar<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-336043" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-336043"><a href="https://www.sentinelcolorado.com/local-events/">Post an event</a></li>
</ul>
</li>
<li id="menu-item-264962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-264962"><a href="https://www.sentinelcolorado.com/sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-270582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270582"><a href="https://www.sentinelcolorado.com/sports/a-town-all-stars/">A-Town All-Stars</a></li>
<li id="menu-item-264965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264965"><a href="https://www.sentinelcolorado.com/sports/sentinel-preps/">Sentinel Preps</a></li>
</ul>
</li>
<li id="menu-item-264973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264973"><a href="https://www.sentinelcolorado.com/contact-us/">Contact Us</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.sentinelcolorado.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
 <div class="td-weather-top-widget" id="td_top_weather_uid">
<i class="td-icons snow-n"></i>
<div class="td-weather-now" data-block-uid="td_top_weather_uid">
<span class="td-big-degrees">48.8</span>
<span class="td-weather-unit">F</span>
</div>
<div class="td-weather-header">
<div class="td-weather-city">Denver</div>
</div>
</div>
</div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SentinelColo" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span> </div> </div>

</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.sentinelcolorado.com/">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg" alt="" />
<span class="td-visual-hidden">Sentinel Colorado</span>
</a>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.sentinelcolorado.com/">
<img class="td-retina-data" data-retina="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-310x73.png" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-310x73.png" alt="" />
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.sentinelcolorado.com/">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg" alt="" />
</a>
</div>
<div class="menu-primary-container"><ul id="menu-primary-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first td-menu-item td-mega-menu menu-item-264972"><a href="https://www.sentinelcolorado.com/metro/">Metro</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5c57969d069db_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_1_5c57969d069db"><script>var block_td_uid_1_5c57969d069db=new tdBlock();block_td_uid_1_5c57969d069db.id="td_uid_1_5c57969d069db";block_td_uid_1_5c57969d069db.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31504","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5c57969d069db_rand","tdc_css_class":"td_uid_1_5c57969d069db_rand","tdc_css_class_style":"td_uid_1_5c57969d069db_rand_style"}';block_td_uid_1_5c57969d069db.td_column_number="3";block_td_uid_1_5c57969d069db.block_type="td_block_mega_menu";block_td_uid_1_5c57969d069db.post_count="5";block_td_uid_1_5c57969d069db.found_posts="586";block_td_uid_1_5c57969d069db.header_color="";block_td_uid_1_5c57969d069db.ajax_pagination_infinite_stop="";block_td_uid_1_5c57969d069db.max_num_pages="118";tdBlocksArray.push(block_td_uid_1_5c57969d069db);</script><div id=td_uid_1_5c57969d069db class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/" rel="bookmark" class="td-image-wrap" title="Man convicted of murder in Colorado woman&#8217;s stabbing"><img width="194" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" srcset="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg 440w, https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice-230x178.jpg 230w, https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice-320x248.jpg 320w" sizes="(max-width: 194px) 100vw, 194px" alt="" title="Man convicted of murder in Colorado woman&#8217;s stabbing" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/" rel="bookmark" title="Man convicted of murder in Colorado woman&#8217;s stabbing">Man convicted of murder in Colorado woman&#8217;s stabbing</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/man-convicted-of-attempting-to-strangle-victim-with-phone-charger-cord-cuts-off-gps-ankle-monitor-absconds-during-arapahoe-county-trial/" rel="bookmark" class="td-image-wrap" title="Police still searching for convict who cut ankle monitor and absconded during trial, new details"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/31134529/Leon-Cabellero_Miguel-logo-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/31134529/Leon-Cabellero_Miguel-logo-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/31134529/Leon-Cabellero_Miguel-logo-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Police still searching for convict who cut ankle monitor and absconded during trial, new details" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/man-convicted-of-attempting-to-strangle-victim-with-phone-charger-cord-cuts-off-gps-ankle-monitor-absconds-during-arapahoe-county-trial/" rel="bookmark" title="Police still searching for convict who cut ankle monitor and absconded during trial, new details">Police still searching for convict who cut ankle monitor and absconded&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/news/metro/city-desk-ryan-frazier-makes-his-bid-for-aurora-mayor-official-saturday/" rel="bookmark" class="td-image-wrap" title="CITY DESK: Ryan Frazier makes his bid for Aurora mayor official Saturday"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/10075514/ryan.frazier.hz_.1.19-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/10075514/ryan.frazier.hz_.1.19-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/10075514/ryan.frazier.hz_.1.19-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="CITY DESK: Ryan Frazier makes his bid for Aurora mayor official Saturday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/news/metro/city-desk-ryan-frazier-makes-his-bid-for-aurora-mayor-official-saturday/" rel="bookmark" title="CITY DESK: Ryan Frazier makes his bid for Aurora mayor official Saturday">CITY DESK: Ryan Frazier makes his bid for Aurora mayor official&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/news/metro/sentinel-pols-congressman-crow-tabbed-for-gun-control-task-force/" rel="bookmark" class="td-image-wrap" title="SENTINEL POLS: Congressman Crow tabbed for gun control task force"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2018/10/16125928/as.ART_.JasonCrowEndorsementMeeting.pbp_.101818.004.web_-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2018/10/16125928/as.ART_.JasonCrowEndorsementMeeting.pbp_.101818.004.web_-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2018/10/16125928/as.ART_.JasonCrowEndorsementMeeting.pbp_.101818.004.web_-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="SENTINEL POLS: Congressman Crow tabbed for gun control task force" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/news/metro/sentinel-pols-congressman-crow-tabbed-for-gun-control-task-force/" rel="bookmark" title="SENTINEL POLS: Congressman Crow tabbed for gun control task force">SENTINEL POLS: Congressman Crow tabbed for gun control task force</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/charter-school-to-open-in-aps-secured-building-location/" rel="bookmark" class="td-image-wrap" title="Charter school to open in APS secured building location"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01131346/Wakanda-bus-picture-539x360-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01131346/Wakanda-bus-picture-539x360-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01131346/Wakanda-bus-picture-539x360-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Charter school to open in APS secured building location" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/charter-school-to-open-in-aps-secured-building-location/" rel="bookmark" title="Charter school to open in APS secured building location">Charter school to open in APS secured building location</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5c57969d069db" data-td_block_id="td_uid_1_5c57969d069db"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5c57969d069db" data-td_block_id="td_uid_1_5c57969d069db"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264971"><a href="https://www.sentinelcolorado.com/metro/nation-and-world/">Colorado, Nation &#038; World</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-264961"><a href="https://www.sentinelcolorado.com/sentinel-biz/">Sentinel Biz</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5c57969d0b097_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_2_5c57969d0b097"><script>var block_td_uid_2_5c57969d0b097=new tdBlock();block_td_uid_2_5c57969d0b097.id="td_uid_2_5c57969d0b097";block_td_uid_2_5c57969d0b097.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31508","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5c57969d0b097_rand","tdc_css_class":"td_uid_2_5c57969d0b097_rand","tdc_css_class_style":"td_uid_2_5c57969d0b097_rand_style"}';block_td_uid_2_5c57969d0b097.td_column_number="3";block_td_uid_2_5c57969d0b097.block_type="td_block_mega_menu";block_td_uid_2_5c57969d0b097.post_count="5";block_td_uid_2_5c57969d0b097.found_posts="410";block_td_uid_2_5c57969d0b097.header_color="";block_td_uid_2_5c57969d0b097.ajax_pagination_infinite_stop="";block_td_uid_2_5c57969d0b097.max_num_pages="82";tdBlocksArray.push(block_td_uid_2_5c57969d0b097);</script><div id=td_uid_2_5c57969d0b097 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
 <div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/buying-a-home-by-age-35-is-worth-it-now-and-later/" rel="bookmark" class="td-image-wrap" title="Buying a home by age 35 is worth it now &#8211; and later"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01090504/AP19028514032388-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01090504/AP19028514032388-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01090504/AP19028514032388-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Buying a home by age 35 is worth it now &#8211; and later" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/buying-a-home-by-age-35-is-worth-it-now-and-later/" rel="bookmark" title="Buying a home by age 35 is worth it now &#8211; and later">Buying a home by age 35 is worth it now &#8211;&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/us-employers-add-robust-304k-jobs-joblessness-up-to-4-pct/" rel="bookmark" class="td-image-wrap" title="US employers add robust 304K jobs; joblessness up to 4 pct."><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01083847/AP19028476009678-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01083847/AP19028476009678-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01083847/AP19028476009678-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="US employers add robust 304K jobs; joblessness up to 4 pct." /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/us-employers-add-robust-304k-jobs-joblessness-up-to-4-pct/" rel="bookmark" title="US employers add robust 304K jobs; joblessness up to 4 pct.">US employers add robust 304K jobs; joblessness up to 4 pct.</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/news/nation-world/world/fears-grow-1-3-of-uk-firms-consider-move-abroad-over-brexit/" rel="bookmark" class="td-image-wrap" title="Fears grow: 1/3 of UK firms consider move abroad over Brexit"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01064351/AP19030770323742-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01064351/AP19030770323742-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01064351/AP19030770323742-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Fears grow: 1/3 of UK firms consider move abroad over Brexit" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/news/nation-world/world/fears-grow-1-3-of-uk-firms-consider-move-abroad-over-brexit/" rel="bookmark" title="Fears grow: 1/3 of UK firms consider move abroad over Brexit">Fears grow: 1/3 of UK firms consider move abroad over Brexit</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/claims-for-us-jobless-benefits-bounce-up-53000-to-253000/" rel="bookmark" class="td-image-wrap" title="Claims for US jobless benefits bounce up 53,000 to 253,000"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/31091126/AP19028477753957-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/31091126/AP19028477753957-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/31091126/AP19028477753957-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Claims for US jobless benefits bounce up 53,000 to 253,000" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/claims-for-us-jobless-benefits-bounce-up-53000-to-253000/" rel="bookmark" title="Claims for US jobless benefits bounce up 53,000 to 253,000">Claims for US jobless benefits bounce up 53,000 to 253,000</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/greens-acres-j-a-green-development-corp-the-latest-to-invest-in-auroras-aerotroplis/" rel="bookmark" class="td-image-wrap" title="GREEN&#8217;S ACRES: J.A. Green Development Corp. the latest to invest in Aurora&#8217;s &#8216;aerotroplis&#8217;"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/31101031/Bldg-1-Entry-View-Revised-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/31101031/Bldg-1-Entry-View-Revised-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/31101031/Bldg-1-Entry-View-Revised-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="GREEN&#8217;S ACRES: J.A. Green Development Corp. the latest to invest in Aurora&#8217;s &#8216;aerotroplis&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/greens-acres-j-a-green-development-corp-the-latest-to-invest-in-auroras-aerotroplis/" rel="bookmark" title="GREEN&#8217;S ACRES: J.A. Green Development Corp. the latest to invest in Aurora&#8217;s &#8216;aerotroplis&#8217;">GREEN&#8217;S ACRES: J.A. Green Development Corp. the latest to invest in&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5c57969d0b097" data-td_block_id="td_uid_2_5c57969d0b097"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5c57969d0b097" data-td_block_id="td_uid_2_5c57969d0b097"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-336101"><a href="https://www.sentinelcolorado.com/obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264968"><a href="https://www.sentinelcolorado.com/metro/your-news/">Your News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-265088"><a href="https://www.sentinelcolorado.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5c57969d0e355_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_3_5c57969d0e355"><script>var block_td_uid_3_5c57969d0e355=new tdBlock();block_td_uid_3_5c57969d0e355.id="td_uid_3_5c57969d0e355";block_td_uid_3_5c57969d0e355.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31516","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_3_5c57969d0e355_rand","tdc_css_class":"td_uid_3_5c57969d0e355_rand","tdc_css_class_style":"td_uid_3_5c57969d0e355_rand_style"}';block_td_uid_3_5c57969d0e355.td_column_number="3";block_td_uid_3_5c57969d0e355.block_type="td_block_mega_menu";block_td_uid_3_5c57969d0e355.post_count="5";block_td_uid_3_5c57969d0e355.found_posts="445";block_td_uid_3_5c57969d0e355.header_color="";block_td_uid_3_5c57969d0e355.ajax_pagination_infinite_stop="";block_td_uid_3_5c57969d0e355.max_num_pages="89";tdBlocksArray.push(block_td_uid_3_5c57969d0e355);</script><div id=td_uid_3_5c57969d0e355 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/opinion/editorial-oregon-measles-outbreak-is-a-reminder-of-colorado-legislatures-vaccine-malfeasance/" rel="bookmark" class="td-image-wrap" title="EDITORIAL: Oregon measles outbreak is a reminder of Colorado Legislature&#8217;s vaccine malfeasance"><img width="218" height="144" class="entry-thumb" src="https://www.sentinelcolorado.com/wp-content/uploads/Arguing-For-Vaccinati_Perr.jpg" srcset="https://www.sentinelcolorado.com/wp-content/uploads/Arguing-For-Vaccinati_Perr.jpg 512w, https://www.sentinelcolorado.com/wp-content/uploads/Arguing-For-Vaccinati_Perr-270x178.jpg 270w, https://www.sentinelcolorado.com/wp-content/uploads/Arguing-For-Vaccinati_Perr-320x211.jpg 320w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="EDITORIAL: Oregon measles outbreak is a reminder of Colorado Legislature&#8217;s vaccine malfeasance" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/opinion/editorial-oregon-measles-outbreak-is-a-reminder-of-colorado-legislatures-vaccine-malfeasance/" rel="bookmark" title="EDITORIAL: Oregon measles outbreak is a reminder of Colorado Legislature&#8217;s vaccine malfeasance">EDITORIAL: Oregon measles outbreak is a reminder of Colorado Legislature&#8217;s vaccine&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridoped/toon-in-friday-191/" rel="bookmark" class="td-image-wrap" title="Toon in Friday"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01101213/20_221153-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01101213/20_221153-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01101213/20_221153-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Toon in Friday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridoped/toon-in-friday-191/" rel="bookmark" title="Toon in Friday">Toon in Friday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/opinion/toon-in-thursday-188/" rel="bookmark" class="td-image-wrap" title="Toon in Thursday"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/31130841/221173_600-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/31130841/221173_600-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/31130841/221173_600-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Toon in Thursday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/opinion/toon-in-thursday-188/" rel="bookmark" title="Toon in Thursday">Toon in Thursday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/opinion/perry-push-back-against-colorado-sex-ed-clowns-and-their-legislative-side-shows/" rel="bookmark" class="td-image-wrap" title="PERRY: Push back against Colorado sex ed clowns and their Legislative side shows"><img width="202" height="150" class="entry-thumb" src="https://www.sentinelcolorado.com/wp-content/uploads/Sex-Education-The-Big_Perr-17.jpg" srcset="https://www.sentinelcolorado.com/wp-content/uploads/Sex-Education-The-Big_Perr-17.jpg 512w, https://www.sentinelcolorado.com/wp-content/uploads/Sex-Education-The-Big_Perr-17-239x178.jpg 239w, https://www.sentinelcolorado.com/wp-content/uploads/Sex-Education-The-Big_Perr-17-484x360.jpg 484w, https://www.sentinelcolorado.com/wp-content/uploads/Sex-Education-The-Big_Perr-17-320x238.jpg 320w" sizes="(max-width: 202px) 100vw, 202px" alt="" title="PERRY: Push back against Colorado sex ed clowns and their Legislative side shows" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/opinion/perry-push-back-against-colorado-sex-ed-clowns-and-their-legislative-side-shows/" rel="bookmark" title="PERRY: Push back against Colorado sex ed clowns and their Legislative side shows">PERRY: Push back against Colorado sex ed clowns and their Legislative&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/opinion/perry-james-holmes-videos-make-a-convincing-argument-for-colorado-gun-control-mental-health-spending/" rel="bookmark" class="td-image-wrap" title="PERRY: James Holmes videos make a convincing argument for Colorado gun control, mental health spending"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/22160102/Screen-Shot-2019-01-22-at-3.58.27-PM-218x150.png" srcset="https://cdn.sentinelcolorado.com/2019/01/22160102/Screen-Shot-2019-01-22-at-3.58.27-PM-218x150.png 218w, https://cdn.sentinelcolorado.com/2019/01/22160102/Screen-Shot-2019-01-22-at-3.58.27-PM-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="PERRY: James Holmes videos make a convincing argument for Colorado gun control, mental health spending" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/opinion/perry-james-holmes-videos-make-a-convincing-argument-for-colorado-gun-control-mental-health-spending/" rel="bookmark" title="PERRY: James Holmes videos make a convincing argument for Colorado gun control, mental health spending">PERRY: James Holmes videos make a convincing argument for Colorado gun&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5c57969d0e355" data-td_block_id="td_uid_3_5c57969d0e355"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5c57969d0e355" data-td_block_id="td_uid_3_5c57969d0e355"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-mega-menu menu-item-264966"><a href="https://www.sentinelcolorado.com/sentinel-magazine/">The Magazine</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5c57969d11036_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_4_5c57969d11036"><script>var block_td_uid_4_5c57969d11036=new tdBlock();block_td_uid_4_5c57969d11036.id="td_uid_4_5c57969d11036";block_td_uid_4_5c57969d11036.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31510","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_4_5c57969d11036_rand","tdc_css_class":"td_uid_4_5c57969d11036_rand","tdc_css_class_style":"td_uid_4_5c57969d11036_rand_style"}';block_td_uid_4_5c57969d11036.td_column_number="3";block_td_uid_4_5c57969d11036.block_type="td_block_mega_menu";block_td_uid_4_5c57969d11036.post_count="5";block_td_uid_4_5c57969d11036.found_posts="592";block_td_uid_4_5c57969d11036.header_color="";block_td_uid_4_5c57969d11036.ajax_pagination_infinite_stop="";block_td_uid_4_5c57969d11036.max_num_pages="119";tdBlocksArray.push(block_td_uid_4_5c57969d11036);</script><div id=td_uid_4_5c57969d11036 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/lighting-her-own-way-former-lumineers-cellist-and-vocalist-neyla-pekarek-releases-solo-album/" rel="bookmark" class="td-image-wrap" title="LIGHTING HER OWN WAY: Former Lumineers cellist and vocalist Neyla Pekarek, releases solo album"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/29091300/Neyla21-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/29091300/Neyla21-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/29091300/Neyla21-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="LIGHTING HER OWN WAY: Former Lumineers cellist and vocalist Neyla Pekarek, releases solo album" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/lighting-her-own-way-former-lumineers-cellist-and-vocalist-neyla-pekarek-releases-solo-album/" rel="bookmark" title="LIGHTING HER OWN WAY: Former Lumineers cellist and vocalist Neyla Pekarek, releases solo album">LIGHTING HER OWN WAY: Former Lumineers cellist and vocalist Neyla Pekarek,&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/from-paris-with-love-dior-exhibit-on-display-at-denver-art-museum-until-march-3/" rel="bookmark" class="td-image-wrap" title="FROM PARIS WITH LOVE: Dior exhibit on display at Denver Art Museum until March 17"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/24113847/Installation-view-of-Dior-From-Paris-to-the-World-at-the-Denver-Art-Museum.-Photograph-by-James-Florio-courtesy-Denver-Art-Museum.-02-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/24113847/Installation-view-of-Dior-From-Paris-to-the-World-at-the-Denver-Art-Museum.-Photograph-by-James-Florio-courtesy-Denver-Art-Museum.-02-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/24113847/Installation-view-of-Dior-From-Paris-to-the-World-at-the-Denver-Art-Museum.-Photograph-by-James-Florio-courtesy-Denver-Art-Museum.-02-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="FROM PARIS WITH LOVE: Dior exhibit on display at Denver Art Museum until March 17" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/from-paris-with-love-dior-exhibit-on-display-at-denver-art-museum-until-march-3/" rel="bookmark" title="FROM PARIS WITH LOVE: Dior exhibit on display at Denver Art Museum until March 17">FROM PARIS WITH LOVE: Dior exhibit on display at Denver Art&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/unseen-j-d-salinger-photos-shot-for-catcher-on-display/" rel="bookmark" class="td-image-wrap" title="Unseen J.D. Salinger photos shot for &#8216;Catcher&#8217; on display"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/23090514/AP19022815229976-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/23090514/AP19022815229976-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/23090514/AP19022815229976-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Unseen J.D. Salinger photos shot for &#8216;Catcher&#8217; on display" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/unseen-j-d-salinger-photos-shot-for-catcher-on-display/" rel="bookmark" title="Unseen J.D. Salinger photos shot for &#8216;Catcher&#8217; on display">Unseen J.D. Salinger photos shot for &#8216;Catcher&#8217; on display</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/sag-honoree-alan-alda-keeps-using-acting-to-make-an-impact/" rel="bookmark" class="td-image-wrap" title="SAG honoree Alan Alda keeps using acting to make an impact"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/23083225/AP18298794230692-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/23083225/AP18298794230692-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/23083225/AP18298794230692-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="SAG honoree Alan Alda keeps using acting to make an impact" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/sag-honoree-alan-alda-keeps-using-acting-to-make-an-impact/" rel="bookmark" title="SAG honoree Alan Alda keeps using acting to make an impact">SAG honoree Alan Alda keeps using acting to make an impact</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/russell-baker-author-and-ny-times-columnist-is-dead-at-93/" rel="bookmark" class="td-image-wrap" title="Russell Baker, author and NY Times columnist is dead at 93"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/23082834/AP19023174050464-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/23082834/AP19023174050464-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/23082834/AP19023174050464-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Russell Baker, author and NY Times columnist is dead at 93" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/russell-baker-author-and-ny-times-columnist-is-dead-at-93/" rel="bookmark" title="Russell Baker, author and NY Times columnist is dead at 93">Russell Baker, author and NY Times columnist is dead at 93</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5c57969d11036" data-td_block_id="td_uid_4_5c57969d11036"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_4_5c57969d11036" data-td_block_id="td_uid_4_5c57969d11036"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-264978"><a href="https://www.sentinelcolorado.com/colorado-table/">Colorado Table</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_5_5c57969d14529_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_5_5c57969d14529"><script>var block_td_uid_5_5c57969d14529=new tdBlock();block_td_uid_5_5c57969d14529.id="td_uid_5_5c57969d14529";block_td_uid_5_5c57969d14529.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31511","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_5_5c57969d14529_rand","tdc_css_class":"td_uid_5_5c57969d14529_rand","tdc_css_class_style":"td_uid_5_5c57969d14529_rand_style"}';block_td_uid_5_5c57969d14529.td_column_number="3";block_td_uid_5_5c57969d14529.block_type="td_block_mega_menu";block_td_uid_5_5c57969d14529.post_count="5";block_td_uid_5_5c57969d14529.found_posts="161";block_td_uid_5_5c57969d14529.header_color="";block_td_uid_5_5c57969d14529.ajax_pagination_infinite_stop="";block_td_uid_5_5c57969d14529.max_num_pages="33";tdBlocksArray.push(block_td_uid_5_5c57969d14529);</script><div id=td_uid_5_5c57969d14529 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridcotable/consider-a-taco-bar-for-super-bowl-entertaining-some-tips/" rel="bookmark" class="td-image-wrap" title="Consider a taco bar for Super Bowl entertaining; some tips"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/30085913/AP19029484898731-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/30085913/AP19029484898731-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/30085913/AP19029484898731-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Consider a taco bar for Super Bowl entertaining; some tips" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridcotable/consider-a-taco-bar-for-super-bowl-entertaining-some-tips/" rel="bookmark" title="Consider a taco bar for Super Bowl entertaining; some tips">Consider a taco bar for Super Bowl entertaining; some tips</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/colorado-table/try-a-classic-french-soup-celebrating-seasonal-vegetables/" rel="bookmark" class="td-image-wrap" title="Try a classic French soup celebrating seasonal vegetables"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/29092651/AP19024815912522-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/29092651/AP19024815912522-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/29092651/AP19024815912522-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Try a classic French soup celebrating seasonal vegetables" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/colorado-table/try-a-classic-french-soup-celebrating-seasonal-vegetables/" rel="bookmark" title="Try a classic French soup celebrating seasonal vegetables">Try a classic French soup celebrating seasonal vegetables</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/colorado-table/a-boozy-coffee-soaked-dessert-awaits-you-with-a-tiramisu/" rel="bookmark" class="td-image-wrap" title="A boozy, coffee-soaked dessert awaits you with a tiramisu"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/29092426/AP19024815967237-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/29092426/AP19024815967237-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/29092426/AP19024815967237-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="A boozy, coffee-soaked dessert awaits you with a tiramisu" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/colorado-table/a-boozy-coffee-soaked-dessert-awaits-you-with-a-tiramisu/" rel="bookmark" title="A boozy, coffee-soaked dessert awaits you with a tiramisu">A boozy, coffee-soaked dessert awaits you with a tiramisu</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridcotable/a-cookie-in-a-skillet-sure-youre-skeptical-but-try-it/" rel="bookmark" class="td-image-wrap" title="A cookie in a skillet? Sure, you&#8217;re skeptical. But try it"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/28110912/AP19024815913225-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/28110912/AP19024815913225-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/28110912/AP19024815913225-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="A cookie in a skillet? Sure, you&#8217;re skeptical. But try it" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridcotable/a-cookie-in-a-skillet-sure-youre-skeptical-but-try-it/" rel="bookmark" title="A cookie in a skillet? Sure, you&#8217;re skeptical. But try it">A cookie in a skillet? Sure, you&#8217;re skeptical. But try it</a></h3> </div>
</div>
</div><div class="td-mega-span">
 <div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/colorado-table/make-an-intense-and-buttery-molten-chocolate-cake-at-home/" rel="bookmark" class="td-image-wrap" title="Make an intense and buttery molten chocolate cake at home"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/28110223/AP19024815916818-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/28110223/AP19024815916818-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/28110223/AP19024815916818-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Make an intense and buttery molten chocolate cake at home" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/colorado-table/make-an-intense-and-buttery-molten-chocolate-cake-at-home/" rel="bookmark" title="Make an intense and buttery molten chocolate cake at home">Make an intense and buttery molten chocolate cake at home</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5c57969d14529" data-td_block_id="td_uid_5_5c57969d14529"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_5_5c57969d14529" data-td_block_id="td_uid_5_5c57969d14529"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-336042"><a href="https://www.sentinelcolorado.com/sentinel-colorado-events-page/">Sentinel Events Calendar</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-336043"><a href="https://www.sentinelcolorado.com/local-events/">Post an event</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-mega-menu menu-item-264962"><a href="https://www.sentinelcolorado.com/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_5c57969d17a07_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_6_5c57969d17a07"><script>var block_td_uid_6_5c57969d17a07=new tdBlock();block_td_uid_6_5c57969d17a07.id="td_uid_6_5c57969d17a07";block_td_uid_6_5c57969d17a07.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31513","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_6_5c57969d17a07_rand","tdc_css_class":"td_uid_6_5c57969d17a07_rand","tdc_css_class_style":"td_uid_6_5c57969d17a07_rand_style"}';block_td_uid_6_5c57969d17a07.td_column_number="3";block_td_uid_6_5c57969d17a07.block_type="td_block_mega_menu";block_td_uid_6_5c57969d17a07.post_count="5";block_td_uid_6_5c57969d17a07.found_posts="683";block_td_uid_6_5c57969d17a07.header_color="";block_td_uid_6_5c57969d17a07.ajax_pagination_infinite_stop="";block_td_uid_6_5c57969d17a07.max_num_pages="137";tdBlocksArray.push(block_td_uid_6_5c57969d17a07);</script><div id=td_uid_6_5c57969d17a07 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/pro/her-knees-broken-beyond-repair-vonn-retiring-after-worlds/" rel="bookmark" class="td-image-wrap" title="Her knees &#8216;broken beyond repair,&#8217; Vonn retiring after worlds"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/02073909/AP19032571109819-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/02073909/AP19032571109819-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/02073909/AP19032571109819-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Her knees &#8216;broken beyond repair,&#8217; Vonn retiring after worlds" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/pro/her-knees-broken-beyond-repair-vonn-retiring-after-worlds/" rel="bookmark" title="Her knees &#8216;broken beyond repair,&#8217; Vonn retiring after worlds">Her knees &#8216;broken beyond repair,&#8217; Vonn retiring after worlds</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridsports/broncos-owner-pat-bowlen-on-cusp-of-hall-of-fame/" rel="bookmark" class="td-image-wrap" title="Broncos owner Pat Bowlen on cusp of Hall of Fame"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01155409/AP19032641779023-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01155409/AP19032641779023-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01155409/AP19032641779023-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Broncos owner Pat Bowlen on cusp of Hall of Fame" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridsports/broncos-owner-pat-bowlen-on-cusp-of-hall-of-fame/" rel="bookmark" title="Broncos owner Pat Bowlen on cusp of Hall of Fame">Broncos owner Pat Bowlen on cusp of Hall of Fame</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/arenado-rockies-agree-at-26m-most-ever-for-arb-eligible/" rel="bookmark" class="td-image-wrap" title="Arenado, Rockies agree at $26M, most ever for arb eligible"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01103058/AP19032020329994-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01103058/AP19032020329994-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01103058/AP19032020329994-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Arenado, Rockies agree at $26M, most ever for arb eligible" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/arenado-rockies-agree-at-26m-most-ever-for-arb-eligible/" rel="bookmark" title="Arenado, Rockies agree at $26M, most ever for arb eligible">Arenado, Rockies agree at $26M, most ever for arb eligible</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/pro/higher-learning-boarder-chloe-kim-aims-to-soar-at-princeton/" rel="bookmark" class="td-image-wrap" title="Higher learning: Boarder Chloe Kim aims to soar at Princeton"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/01064653/AP19029580411674-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/01064653/AP19029580411674-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/01064653/AP19029580411674-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Higher learning: Boarder Chloe Kim aims to soar at Princeton" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/pro/higher-learning-boarder-chloe-kim-aims-to-soar-at-princeton/" rel="bookmark" title="Higher learning: Boarder Chloe Kim aims to soar at Princeton">Higher learning: Boarder Chloe Kim aims to soar at Princeton</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridsports/patriots-put-72-dolphins-in-their-sights-in-different-way/" rel="bookmark" class="td-image-wrap" title="Patriots put &#8217;72 Dolphins in their sights in different way"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/01/31085427/AP19031032287556-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/01/31085427/AP19031032287556-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/01/31085427/AP19031032287556-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Patriots put &#8217;72 Dolphins in their sights in different way" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridsports/patriots-put-72-dolphins-in-their-sights-in-different-way/" rel="bookmark" title="Patriots put &#8217;72 Dolphins in their sights in different way">Patriots put &#8217;72 Dolphins in their sights in different way</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5c57969d17a07" data-td_block_id="td_uid_6_5c57969d17a07"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_5c57969d17a07" data-td_block_id="td_uid_6_5c57969d17a07"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270582"><a href="https://www.sentinelcolorado.com/sports/a-town-all-stars/">A-Town All-Stars</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264965"><a href="https://www.sentinelcolorado.com/sports/sentinel-preps/">Sentinel Preps</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264973"><a href="https://www.sentinelcolorado.com/contact-us/">Contact Us</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.sentinelcolorado.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  td_uid_7_5c57969d1c7ec_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-3'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-3');});</script>
</div>
</div></div>
</div> </div>
</div>
</div>
</div><div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-5 ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.sentinelcolorado.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in 0Recent Headlines" class="entry-crumb" href="https://www.sentinelcolorado.com/category/orecent-headlines/">0Recent Headlines</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Man convicted of murder in Colorado woman&#8217;s stabbing</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-340344" class="post-340344 post type-post status-publish format-standard has-post-thumbnail category-orecent-headlines category-0trending category-1gridmetro category-metro category-police-courts category-y-am-edition-local" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/orecent-headlines/">0Recent Headlines</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/metro/">Metro</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/metro/police-courts/">Police &amp; Courts</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/y-am-edition-local/">Y AM edition - LOCAL</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Man convicted of murder in Colorado woman&#8217;s stabbing</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.sentinelcolorado.com/author/theassociatedpress/">THE ASSOCIATED PRESS</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-02-03T18:21:12+00:00">February 3, 2019</time></span> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-340344">3</span></div> </div>
</header>
</div>
<div class="td-post-sharing-top"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Man+convicted+of+murder+in+Colorado+woman%E2%80%99s+stabbing&url=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F&via=SentinelColo">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#7c430f091e16191f0841311d125c1f13120a151f0819185c131a5c11090e18190e5c15125c3f1310130e1d18135c0b13111d125a5f444e4d4b470f5c0f081d1e1e15121b5a1e131805411408080c0f4653530b0b0b520f191208151219101f1310130e1d1813521f13115312190b0f531119080e1353111d12511f13120a151f08191851131a5111090e18190e511512511f1310130e1d1813510b13111d120f510f081d1e1e15121b53">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content">
<p><strong>CASTLE ROCK</strong> |  Colorado prosecutors say a man who repeatedly stabbed a woman and then dumped her body alongside a highway has been found guilty of first-degree murder and is facing a lifetime prison sentence.</p>
<p>Douglas County jurors on Friday also found 38-year-old Mihail Petrov guilty of seven other charges in the death of 24-year-old Shelby Weatherly.</p>
<p>Weatherly&#8217;s body was found on the side of Interstate 25 in Douglas County in September of 2017. An autopsy found she had been stabbed 19 times.</p>
<p>Prosecutors said police found Weatherly&#8217;s blood on Petrov&#8217;s clothing and inside his car and determined that Petrov&#8217;s fingerprints were on items found with the woman&#8217;s body. Authorities also said Petrov told two people he had killed someone.</p>
<p>Petrov is set to be sentenced on April 30.</p>
</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Man+convicted+of+murder+in+Colorado+woman%E2%80%99s+stabbing&url=https%3A%2F%2Fwww.sentinelcolorado.com%2Fnews%2Fmetro%2Fman-convicted-of-murder-in-colorado-womans-stabbing%2F&via=SentinelColo">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#af90dcdacdc5caccdb92e2cec18fccc0c1d9c6ccdbcacb8fc0c98fc2daddcbcadd8fc6c18fecc0c3c0ddcecbc08fd8c0c2cec1898c979d9e9894dc8fdcdbcecdcdc6c1c889cdc0cbd692c7dbdbdfdc958080d8d8d881dccac1dbc6c1cac3ccc0c3c0ddcecbc081ccc0c280c1cad8dc80c2cadbddc080c2cec182ccc0c1d9c6ccdbcacb82c0c982c2daddcbcadd82c6c182ccc0c3c0ddcecbc082d8c0c2cec1dc82dcdbcecdcdc6c1c880">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.sentinelcolorado.com/sports/preps/girls-swimming/girls-swimming-2019-centennial-a-league-championship-meet-results/">Girls Swimming: 2019 Centennial &#8220;A&#8221; League Championship meet results</a></div></div><div class="td-next-prev-separator"></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.sentinelcolorado.com/author/theassociatedpress/">THE ASSOCIATED PRESS</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="THE ASSOCIATED PRESS"></span><meta itemprop="datePublished" content="2019-02-03T18:21:12+00:00"><meta itemprop="dateModified" content="2019-02-03T18:21:12+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.sentinelcolorado.com/news/metro/man-convicted-of-murder-in-colorado-womans-stabbing/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg"></span><meta itemprop="name" content="Sentinel Colorado"></span><meta itemprop="headline " content="Man convicted of murder in Colorado woman&#039;s stabbing"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg"><meta itemprop="width" content="440"><meta itemprop="height" content="341"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_9_5c57969d1f025_rand td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_9_5c57969d1f025"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_9_5c57969d1f025=new tdBlock();block_td_uid_9_5c57969d1f025.id="td_uid_9_5c57969d1f025";block_td_uid_9_5c57969d1f025.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_9_5c57969d1f025_rand","td_column_number":3,"live_filter_cur_post_id":340344,"live_filter_cur_post_author":"49","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_9_5c57969d1f025_rand","tdc_css_class_style":"td_uid_9_5c57969d1f025_rand_style"}';block_td_uid_9_5c57969d1f025.td_column_number="3";block_td_uid_9_5c57969d1f025.block_type="td_block_related_posts";block_td_uid_9_5c57969d1f025.post_count="3";block_td_uid_9_5c57969d1f025.found_posts="13452";block_td_uid_9_5c57969d1f025.header_color="";block_td_uid_9_5c57969d1f025.ajax_pagination_infinite_stop="";block_td_uid_9_5c57969d1f025.max_num_pages="4484";tdBlocksArray.push(block_td_uid_9_5c57969d1f025);</script><h4 class="td-related-title td-block-title"><a id="td_uid_10_5c57969d1fa95" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_9_5c57969d1f025" href="#">RELATED ARTICLES</a><a id="td_uid_11_5c57969d1fad8" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_9_5c57969d1f025" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_9_5c57969d1f025 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/preps/girls-swimming/girls-swimming-2019-centennial-a-league-championship-meet-results/" rel="bookmark" class="td-image-wrap" title="Girls Swimming: 2019 Centennial &#8220;A&#8221; League Championship meet results"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/03152146/WMNLow.CentStart1958FB3200-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/03152146/WMNLow.CentStart1958FB3200-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/03152146/WMNLow.CentStart1958FB3200-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Girls Swimming: 2019 Centennial &#8220;A&#8221; League Championship meet results" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/preps/girls-swimming/girls-swimming-2019-centennial-a-league-championship-meet-results/" rel="bookmark" title="Girls Swimming: 2019 Centennial &#8220;A&#8221; League Championship meet results">Girls Swimming: 2019 Centennial &#8220;A&#8221; League Championship meet results</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/blood-test-problems-stop-boulder-drugging-investigation/" rel="bookmark" class="td-image-wrap" title="Blood test problems stop Boulder drugging investigation"><img width="194" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg" srcset="https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice.jpg 440w, https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice-230x178.jpg 230w, https://cdn.sentinelcolorado.com/asuplads/20180226194945/SentinelBadgePolice-320x248.jpg 320w" sizes="(max-width: 194px) 100vw, 194px" alt="" title="Blood test problems stop Boulder drugging investigation" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/blood-test-problems-stop-boulder-drugging-investigation/" rel="bookmark" title="Blood test problems stop Boulder drugging investigation">Blood test problems stop Boulder drugging investigation</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/1-deputy-killed-another-wounded-in-12-hour-standoff-in-ohio/" rel="bookmark" class="td-image-wrap" title="1 deputy killed, another wounded in 12-hour standoff in Ohio"><img width="218" height="150" class="entry-thumb" src="https://cdn.sentinelcolorado.com/2019/02/03124916/AP19034559346673-218x150.jpg" srcset="https://cdn.sentinelcolorado.com/2019/02/03124916/AP19034559346673-218x150.jpg 218w, https://cdn.sentinelcolorado.com/2019/02/03124916/AP19034559346673-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="1 deputy killed, another wounded in 12-hour standoff in Ohio" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/1-deputy-killed-another-wounded-in-12-hour-standoff-in-ohio/" rel="bookmark" title="1 deputy killed, another wounded in 12-hour standoff in Ohio">1 deputy killed, another wounded in 12-hour standoff in Ohio</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_9_5c57969d1f025" data-td_block_id="td_uid_9_5c57969d1f025"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_9_5c57969d1f025" data-td_block_id="td_uid_9_5c57969d1f025"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div id="disqus_thread"></div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_12_5c57969d214dd_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-4' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-4');});</script>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_5  td_uid_13_5c57969d2172d_rand td_block_template_11">
<div id='div-gpt-ad-1528827699928-0' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1528827699928-0');});</script>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_2  td_uid_14_5c57969d2190d_rand td_block_template_11">
<div id='div-gpt-ad-1520977200202-5' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-5');});</script>
</div>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_3  td_uid_15_5c57969d21aed_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-6' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-6');});</script>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_4  td_uid_16_5c57969d21cba_rand td_block_template_11">
<div id='div-gpt-ad-1520977200202-7' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-7');});</script>
</div>
</div></div> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap td-footer-template-4 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.sentinelcolorado.com/"><img class="td-retina-data" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-e1520024990897.png" data-retina="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer.png" alt="sentinel colorado" title="sentinel colorado" width="250" /></a></div><div class="footer-text-wrap"><div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#ceb9abaca3afbdbaabbc8eafbbbca1bcafbdaba0baa7a0aba2e0ada1a3"><span class="__cf_email__" data-cfemail="384f5d5a55594b4c5d4a78594d4a574a594b5d564c51565d54165b5755">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SentinelColo" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span></div></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; 2018 Aurora Sentinel. All rights reserved. <a href="https://www.enviemedia.com" target="_blank" title="colorado website design and development company">Colorado-proud website development</a> by Envie Media. </div>
</div>
</div>
</div>
</div>
<div style="display:none">
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>//<![CDATA[
var countVars={"disqusShortname":"aurorasentinel"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>//<![CDATA[
var embedVars={"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"340344 https:\/\/www.sentinelcolorado.com\/?p=340344","disqusShortname":"aurorasentinel","disqusTitle":"Man convicted of murder in Colorado woman\u2019s stabbing","disqusUrl":"https:\/\/www.sentinelcolorado.com\/news\/metro\/man-convicted-of-murder-in-colorado-womans-stabbing\/","postId":"340344"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201906'></script>
<script type='text/javascript'>//<![CDATA[
var tCountAjax={"ajaxurl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php","countdownNonce":"d483b1c09a"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/jquery-t-countdown-widget/js/jquery.t-countdown.js?ver=2.4.0'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Febaa'></script>
<script type='text/javascript'>//<![CDATA[
var WPGroHo={"my_hash":""};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=6f76e43ca7be939a13665c4f3c131794'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.0.1'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b374619cdb09c180dbf43dd944b44575'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/wp-embed.min.js?ver=6f76e43ca7be939a13665c4f3c131794'></script>

<script>jQuery().ready(function(){tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Denver","api_location":"Denver","api_language":"en","api_key":"eee53618725b7d26226f3b8b89b32780","today_icon":"snow-n","today_icon_text":"shower snow","today_temp":[9.3,48.8],"today_humidity":36,"today_wind_speed":[8.2,5.1],"today_min":[5,41],"today_max":[11.1,52],"today_clouds":1,"current_unit":1,"forecast":[{"timestamp":1549249200,"day_name":"Mon","day_temp":[12,53],"owm_day_index":0},{"timestamp":1549324800,"day_name":"Tue","day_temp":[9,48],"owm_day_index":7},{"timestamp":1549411200,"day_name":"Wed","day_temp":[6,43],"owm_day_index":15},{"timestamp":1549497600,"day_name":"Thu","day_temp":[-2,28],"owm_day_index":23},{"timestamp":1549584000,"day_name":"Fri","day_temp":[-4,25],"owm_day_index":31}]});});jQuery().ready(function jQuery_ready(){tdAjaxCount.tdGetViewsCountsAjax("post","[340344]");});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.sentinelcolorado.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
 <header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>(function(jQuery,undefined){jQuery(window).ready(function(){if('undefined'!==typeof tdcAdminIFrameUI){var $liveIframe=tdcAdminIFrameUI.getLiveIframe();if($liveIframe.length){$liveIframe.load(function(){$liveIframe.contents().find('body').append('<textarea class="tdw-css-writer-editor" style="display: none"></textarea>');});}}});})(jQuery);</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_5c57969d25423"></textarea>
<div id="td_live_css_uid_1_5c57969d25423" class="td-code-editor"></div>
<script>jQuery(window).load(function(){if('undefined'!==typeof tdLiveCssInject){tdLiveCssInject.init();var editor_textarea=jQuery('.td_live_css_uid_1_5c57969d25423');var languageTools=ace.require("ace/ext/language_tools");var tdcCompleter={getCompletions:function(editor,session,pos,prefix,callback){if(prefix.length===0){callback(null,[]);return}
if('undefined'!==typeof tdcAdminIFrameUI){var data={error:undefined,getShortcode:''};tdcIFrameData.getShortcodeFromData(data);if(!_.isUndefined(data.error)){tdcDebug.log(data.error);}
if(!_.isUndefined(data.getShortcode)){var regex=/el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,results=data.getShortcode.match(regex);var elClasses={};for(var i=0;i<results.length;i++){var currentClasses=results[i].replace('el_class="','').replace('"','').split(' ');for(var j=0;j<currentClasses.length;j++){if(_.isUndefined(elClasses[currentClasses[j]])){elClasses[currentClasses[j]]='';}}}
var arrElClasses=[];for(var prop in elClasses){arrElClasses.push(prop);}
callback(null,arrElClasses.map(function(item){return{name:item,value:item,meta:'in_page'}}));}}}};languageTools.addCompleter(tdcCompleter);window.editor=ace.edit("td_live_css_uid_1_5c57969d25423");window.editorChangeHandler=function(){window.onbeforeunload=function(){if(tdwState.lessWasEdited){return"You have attempted to leave this page. Are you sure?";}
return false;};var editorValue=editor.getSession().getValue();editor_textarea.val(editorValue);if('undefined'!==typeof tdcAdminIFrameUI){tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);tdcMain.setContentModified();}
tdLiveCssInject.less();};editor.getSession().setValue(editor_textarea.val());editor.getSession().on('change',editorChangeHandler);editor.setTheme("ace/theme/textmate");editor.setShowPrintMargin(false);editor.getSession().setMode("ace/mode/less");editor.setOptions({enableBasicAutocompletion:true,enableSnippets:true,enableLiveAutocompletion:false});}});</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
</body>
</html>