<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.sentinelcolorado.com/xmlrpc.php" />
<meta property="og:image" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg" />

<title>Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek - Sentinel Colorado</title>
<link rel="canonical" href="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek - Sentinel Colorado" />
<meta property="og:description" content="The state&#039;s largest teachers union and organizer of the rallies, the Colorado Education Association, has endorsed former state treasurer Cary Kennedy for the Democratic nomination. She drew cheers when she called for a change to the state&#039;s strict tax-and-spending limits" />
<meta property="og:url" content="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/" />
<meta property="og:site_name" content="Sentinel Colorado" />
<meta property="article:publisher" content="https://www.facebook.com/theaurorasentinel" />
<meta property="article:section" content="1gridHOME" />
<meta property="article:published_time" content="2018-04-28T09:22:36-06:00" />
<meta property="article:modified_time" content="2018-04-28T17:32:55-06:00" />
<meta property="og:updated_time" content="2018-04-28T17:32:55-06:00" />
<meta property="og:image" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg" />
<meta property="og:image:secure_url" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Feed" href="https://www.sentinelcolorado.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Comments Feed" href="https://www.sentinelcolorado.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Colorado &raquo; Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek Comments Feed" href="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/feed/" />
<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sentinelcolorado.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=bfc51f3a494d884bb3b131714fa811cd"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>

<link rel='stylesheet' id='mec-font-icons-css' href='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/css/iconfonts.css?ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<link rel='stylesheet' id='mec-frontend-style-css' href='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/css/frontend.min.css?ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<link rel='stylesheet' id='mec-google-fonts-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7CRoboto%3A100%2C300%2C400%2C700&#038;ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<link rel='stylesheet' id='mec-dynamic-styles-css' href='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/css/dyncss.css?ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<style id='mec-dynamic-styles-inline-css' type='text/css'>.mec-wrap.colorskin-custom .mec-calendar.mec-event-calendar-classic .mec-selected-day,.mec-wrap.colorskin-custom .mec-color,.mec-wrap.colorskin-custom .mec-event-sharing-wrap .mec-event-sharing>li:hover a,.mec-wrap.colorskin-custom .mec-color-hover:hover,.mec-wrap.colorskin-custom .mec-color-before *:before,.mec-wrap.colorskin-custom .mec-widget .mec-event-grid-classic.owl-carousel .owl-nav i,.mec-wrap.colorskin-custom .mec-event-list-classic a.magicmore:hover,.mec-wrap.colorskin-custom .mec-event-grid-simple:hover .mec-event-title,.mec-wrap.colorskin-custom .mec-single-event .mec-event-meta dd.mec-events-event-categories:before,.mec-wrap.colorskin-custom .mec-single-event-date:before,.mec-wrap.colorskin-custom .mec-single-event-time:before,.mec-wrap.colorskin-custom .mec-events-meta-group.mec-events-meta-group-venue:before,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-side .mec-previous-month i,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-side .mec-next-month,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-side .mec-previous-month:hover,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-side .mec-next-month:hover,.mec-wrap.colorskin-custom .mec-calendar.mec-event-calendar-classic dt.mec-selected-day:hover,.mec-wrap.colorskin-custom .mec-infowindow-wp h5 a:hover,.colorskin-custom .mec-events-meta-group-countdown .mec-end-counts h3,.mec-calendar .mec-calendar-side .mec-next-month i,.mec-wrap .mec-totalcal-box i,.mec-calendar .mec-event-article .mec-event-title a:hover,.mec-attendees-list-details .mec-attendee-profile-link a:hover,.mec-next-event-details li i,.mec-next-event-details a{color:#c0223c}.mec-wrap.colorskin-custom .mec-event-sharing .mec-event-share:hover .event-sharing-icon,.mec-wrap.colorskin-custom .mec-event-grid-clean .mec-event-date,.mec-wrap.colorskin-custom .mec-event-list-modern .mec-event-sharing > li:hover a i,.mec-wrap.colorskin-custom .mec-event-list-modern .mec-event-sharing .mec-event-share:hover .mec-event-sharing-icon,.mec-wrap.colorskin-custom .mec-event-list-modern .mec-event-sharing li:hover a i,.mec-wrap.colorskin-custom .mec-calendar:not(.mec-event-calendar-classic) .mec-selected-day,.mec-wrap.colorskin-custom .mec-calendar .mec-selected-day:hover,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-row  dt.mec-has-event:hover,.mec-wrap.colorskin-custom .mec-calendar .mec-has-event:after, .mec-wrap.colorskin-custom .mec-bg-color, .mec-wrap.colorskin-custom .mec-bg-color-hover:hover, .colorskin-custom .mec-event-sharing-wrap:hover > li, .mec-wrap.colorskin-custom .mec-totalcal-box .mec-totalcal-view span.mec-totalcalview-selected,.mec-wrap .flip-clock-wrapper ul li a div div.inn,.mec-wrap .mec-totalcal-box .mec-totalcal-view span.mec-totalcalview-selected,.event-carousel-type1-head .mec-event-date-carousel,.mec-event-countdown-style3 .mec-event-date,#wrap .mec-wrap article.mec-event-countdown-style1,.mec-event-countdown-style1 .mec-event-countdown-part3 a.mec-event-button,.mec-wrap .mec-event-countdown-style2,.mec-map-get-direction-btn-cnt input[type="submit"],.mec-booking button,span.mec-marker-wrap{background-color:#c0223c}.mec-wrap.colorskin-custom .mec-event-list-modern .mec-event-sharing>li:hover a i,.mec-wrap.colorskin-custom .mec-event-list-modern .mec-event-sharing .mec-event-share:hover .mec-event-sharing-icon,.mec-wrap.colorskin-custom .mec-event-list-standard .mec-month-divider span:before,.mec-wrap.colorskin-custom .mec-single-event .mec-social-single:before,.mec-wrap.colorskin-custom .mec-single-event .mec-frontbox-title:before,.mec-wrap.colorskin-custom .mec-calendar .mec-calendar-events-side .mec-table-side-day,.mec-wrap.colorskin-custom .mec-border-color,.mec-wrap.colorskin-custom .mec-border-color-hover:hover,.colorskin-custom .mec-single-event .mec-frontbox-title:before,.colorskin-custom .mec-single-event .mec-events-meta-group-booking form>h4:before,.mec-wrap.colorskin-custom .mec-totalcal-box .mec-totalcal-view span.mec-totalcalview-selected,.mec-wrap .mec-totalcal-box .mec-totalcal-view span.mec-totalcalview-selected,.event-carousel-type1-head .mec-event-date-carousel:after{border-color:#c0223c}.mec-event-countdown-style3 .mec-event-date:after{border-bottom-color:#c0223c}.mec-wrap article.mec-event-countdown-style1 .mec-event-countdown-part2:after{border-color:transparent transparent transparent #c0223c}</style>
<link rel='stylesheet' id='mec-lity-style-css' href='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/packages/lity/lity.min.css?ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css' href='https://www.sentinelcolorado.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.92' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css' href='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.sentinelcolorado.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://www.sentinelcolorado.com/wp-content/plugins/addthis-all/frontend/build/addthis_wordpress_public.min.css?ver=bfc51f3a494d884bb3b131714fa811cd' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css' href='https://www.sentinelcolorado.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/css/wpmu-ui.3.min.css?ver=3.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css' href='https://www.sentinelcolorado.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/css/animate.3.min.css?ver=3.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/style.css?ver=8.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>//<![CDATA[
var related_posts_js_options={"post_heading":"h4"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script>
<script type='text/javascript'>//<![CDATA[
var mecdata={"day":"day","days":"days","hour":"hour","hours":"hours","minute":"minute","minutes":"minutes","second":"second","seconds":"seconds"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/js/frontend.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/js/events.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/packages/lity/lity.min.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/modern-events-calendar/assets/packages/owl-carousel/owl.carousel.min.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/wp-a11y.min.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript'>//<![CDATA[
var uiAutocompleteL10n={"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>//<![CDATA[
var EM={"ajaxurl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php","locationajaxurl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"mm\/dd\/yy","ui_css":"https:\/\/www.sentinelcolorado.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.css","show24hours":"0","is_ssl":"1","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.92'></script>
<link rel='https://api.w.org/' href='https://www.sentinelcolorado.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sentinelcolorado.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sentinelcolorado.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/p9HOAz-1b6j' />
<link rel="alternate" type="application/json+oembed" href="https://www.sentinelcolorado.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelcolorado.com%2F1gridhome%2Fthousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sentinelcolorado.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelcolorado.com%2F1gridhome%2Fthousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek%2F&#038;format=xml" />
<script type="text/javascript">(function(url){if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){return;}
var addEvent=function(evt,handler){if(window.addEventListener){document.addEventListener(evt,handler,false);}else if(window.attachEvent){document.attachEvent('on'+evt,handler);}};var removeEvent=function(evt,handler){if(window.removeEventListener){document.removeEventListener(evt,handler,false);}else if(window.detachEvent){document.detachEvent('on'+evt,handler);}};var evts='contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');var logHuman=function(){var wfscr=document.createElement('script');wfscr.type='text/javascript';wfscr.async=true;wfscr.src=url+'&r='+Math.random();(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);for(var i=0;i<evts.length;i++){removeEvent(evts[i],logHuman);}};for(var i=0;i<evts.length;i++){addEvent(evts[i],logHuman);}})('//www.sentinelcolorado.com/?wordfence_lh=1&hid=8BAE321FE7DF5A0296CA8C5281ECC25A');</script><style type="text/css" id="ub_admin_bar_logo">body #wpadminbar #wp-admin-bar-wp-logo>.ab-item{background-image:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301002711/icon-sm.png);background-repeat:no-repeat;background-position:50%;background-size:80%}body #wpadminbar #wp-admin-bar-wp-logo>.ab-item .ab-icon:before{content:" "}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <script>window.tdwGlobal={"adminUrl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/","wpRestNonce":"857475b63b","wpRestUrl":"https:\/\/www.sentinelcolorado.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};</script>
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";var td_ajax_url="https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.7.3";var td_get_template_directory_uri="https:\/\/www.sentinelcolorado.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="10";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="1";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#c0223b";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-31800290-1','auto');ga('require','displayfeatures');ga('send','pageview');</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.sentinelcolorado.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.sentinelcolorado.com/category/0trending/",
                                "name": "0Trending"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/",
                                "name": "Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry..."                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/06113526/cropped-SentinelFlag-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/06113526/cropped-SentinelFlag-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/06113526/cropped-SentinelFlag-180x180.png" />
<meta name="msapplication-TileImage" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/06113526/cropped-SentinelFlag-270x270.png" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script>
<script>googletag.cmd.push(function(){googletag.defineSlot('/8540113/120x60_Search',[120,60],'div-gpt-ad-1520977200202-0').addService(googletag.pubads());googletag.defineSlot('/8540113/468x60_Footer',[[728,90],[468,60],[960,90]],'div-gpt-ad-1520977200202-1').addService(googletag.pubads());googletag.defineSlot('/8540113/468x60_ROS',[468,60],'div-gpt-ad-1520977200202-2').addService(googletag.pubads());googletag.defineSlot('/8540113/960x90_ROS',[[728,90],[960,90]],'div-gpt-ad-1520977200202-3').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_1',[300,250],'div-gpt-ad-1520977200202-4').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_2',[300,250],'div-gpt-ad-1520977200202-5').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_3',[300,250],'div-gpt-ad-1520977200202-6').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x250_Right_4',[300,250],'div-gpt-ad-1520977200202-7').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_1',[300,40],'div-gpt-ad-1520977200202-8').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_2',[300,40],'div-gpt-ad-1520977200202-9').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_3',[300,40],'div-gpt-ad-1520977200202-10').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_4',[300,40],'div-gpt-ad-1520977200202-11').addService(googletag.pubads());googletag.defineSlot('/8540113/AS_300x40_5',[300,40],'div-gpt-ad-1520977200202-12').addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});</script> <style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-281003 single-format-standard thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek global-block-template-11 single_template_5 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/AuroraSentinel" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-primary-container"><ul id="menu-primary" class="td-mobile-main-menu"><li id="menu-item-264972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first menu-item-264972"><a href="https://www.sentinelcolorado.com/metro/">Metro<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-264971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264971"><a href="https://www.sentinelcolorado.com/metro/nation-and-world/">Colorado, Nation &#038; World</a></li>
<li id="menu-item-272636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-272636"><a href="https://www.sentinelcolorado.com/sentinel-voter-guide-2018/">Sentinel Voter Guide 2018</a></li>
<li id="menu-item-264968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264968"><a href="https://www.sentinelcolorado.com/metro/your-news/">Your News</a></li>
</ul>
</li>
<li id="menu-item-264961" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264961"><a href="https://www.sentinelcolorado.com/sentinel-biz/">Sentinel Biz</a></li>
<li id="menu-item-265088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-265088"><a href="https://www.sentinelcolorado.com/opinion/">Opinion</a></li>
<li id="menu-item-264978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264978"><a href="https://www.sentinelcolorado.com/colorado-table/">Colorado Table</a></li>
<li id="menu-item-264966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264966"><a href="https://www.sentinelcolorado.com/sentinel-magazine/">The Magazine</a></li>
<li id="menu-item-264962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-264962"><a href="https://www.sentinelcolorado.com/sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-270582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270582"><a href="https://www.sentinelcolorado.com/sports/a-town-all-stars/">A-Town All-Stars</a></li>
<li id="menu-item-264965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264965"><a href="https://www.sentinelcolorado.com/sports/sentinel-preps/">Sentinel Preps</a></li>
</ul>
</li>
<li id="menu-item-264973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264973"><a href="https://www.sentinelcolorado.com/contact-us/">Contact Us</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.sentinelcolorado.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
 <div class="td-weather-top-widget" id="td_top_weather_uid">
<i class="td-icons clear-sky-d"></i>
<div class="td-weather-now" data-block-uid="td_top_weather_uid">
<span class="td-big-degrees">52.7</span>
<span class="td-weather-unit">F</span>
</div>
<div class="td-weather-header">
<div class="td-weather-city">Aurora</div>
</div>
</div>
</div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/AuroraSentinel" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span> </div> </div>

</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.sentinelcolorado.com/">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg" alt="" />
<span class="td-visual-hidden">Sentinel Colorado</span>
</a>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.sentinelcolorado.com/">
<img class="td-retina-data" data-retina="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-310x73.png" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-310x73.png" alt="" />
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.sentinelcolorado.com/">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg" alt="" />
</a>
</div>
<div class="menu-primary-container"><ul id="menu-primary-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first td-menu-item td-mega-menu menu-item-264972"><a href="https://www.sentinelcolorado.com/metro/">Metro</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5ae506936be7d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_1_5ae506936be7d"><script>var block_td_uid_1_5ae506936be7d=new tdBlock();block_td_uid_1_5ae506936be7d.id="td_uid_1_5ae506936be7d";block_td_uid_1_5ae506936be7d.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31504","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5ae506936be7d_rand","tdc_css_class":"td_uid_1_5ae506936be7d_rand","tdc_css_class_style":"td_uid_1_5ae506936be7d_rand_style"}';block_td_uid_1_5ae506936be7d.td_column_number="3";block_td_uid_1_5ae506936be7d.block_type="td_block_mega_menu";block_td_uid_1_5ae506936be7d.post_count="5";block_td_uid_1_5ae506936be7d.found_posts="121";block_td_uid_1_5ae506936be7d.header_color="";block_td_uid_1_5ae506936be7d.ajax_pagination_infinite_stop="";block_td_uid_1_5ae506936be7d.max_num_pages="25";tdBlocksArray.push(block_td_uid_1_5ae506936be7d);</script><div id=td_uid_1_5ae506936be7d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/centennial-man-convicted-of-killing-estranged-wife-in-front-of-teen-son/" rel="bookmark" class="td-image-wrap" title="Centennial man convicted of killing estranged wife in front of teen son"><img width="194" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice.jpg 440w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice-230x178.jpg 230w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice-320x248.jpg 320w" sizes="(max-width: 194px) 100vw, 194px" alt="" title="Centennial man convicted of killing estranged wife in front of teen son" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/centennial-man-convicted-of-killing-estranged-wife-in-front-of-teen-son/" rel="bookmark" title="Centennial man convicted of killing estranged wife in front of teen son">Centennial man convicted of killing estranged wife in front of teen&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/" rel="bookmark" class="td-image-wrap" title="Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/" rel="bookmark" title="Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek">Thousands more teachers protest at Colorado Capitol, including those from APS,&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/money-from-pot-taxes-doesnt-fix-colorado-teachers-problems/" rel="bookmark" class="td-image-wrap" title="Money from pot taxes doesn&#8217;t fix Colorado teachers&#8217; problems"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27073023/AP18115789636150-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27073023/AP18115789636150-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27073023/AP18115789636150-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27073023/AP18115789636150-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Money from pot taxes doesn&#8217;t fix Colorado teachers&#8217; problems" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/money-from-pot-taxes-doesnt-fix-colorado-teachers-problems/" rel="bookmark" title="Money from pot taxes doesn&#8217;t fix Colorado teachers&#8217; problems">Money from pot taxes doesn&#8217;t fix Colorado teachers&#8217; problems</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/city-desk-aurora-looks-for-r-line-stars-to-promote-commerical-psas/" rel="bookmark" class="td-image-wrap" title="CITY DESK: Aurora looks for R Line stars to promote commercial PSAs"><img width="218" height="145" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170920134013/as.ART_.RTD_.pbp_.092117.002.web_.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170920134013/as.ART_.RTD_.pbp_.092117.002.web_.jpg 600w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170920134013/as.ART_.RTD_.pbp_.092117.002.web_-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170920134013/as.ART_.RTD_.pbp_.092117.002.web_-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170920134013/as.ART_.RTD_.pbp_.092117.002.web_-320x213.jpg 320w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="CITY DESK: Aurora looks for R Line stars to promote commercial PSAs" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/city-desk-aurora-looks-for-r-line-stars-to-promote-commerical-psas/" rel="bookmark" title="CITY DESK: Aurora looks for R Line stars to promote commercial PSAs">CITY DESK: Aurora looks for R Line stars to promote commercial&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/sentinel-pols-everything-you-need-to-know-about-cd6-candidate-levi-tillemanns-secret-recording-with-congressman-steny-hoyer/" rel="bookmark" class="td-image-wrap" title="SENTINEL POLS: Everything you need to know about CD6 candidate Levi Tillemann’s secret recording with Congressman Steny Hoyer"><img width="138" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000.jpeg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000.jpeg 1946w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-163x178.jpeg 163w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-768x837.jpeg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-330x360.jpeg 330w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-610x665.jpeg 610w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-1024x1116.jpeg 1024w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170710133247/File_000-320x349.jpeg 320w" sizes="(max-width: 138px) 100vw, 138px" alt="" title="SENTINEL POLS: Everything you need to know about CD6 candidate Levi Tillemann’s secret recording with Congressman Steny Hoyer" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/sentinel-pols-everything-you-need-to-know-about-cd6-candidate-levi-tillemanns-secret-recording-with-congressman-steny-hoyer/" rel="bookmark" title="SENTINEL POLS: Everything you need to know about CD6 candidate Levi Tillemann’s secret recording with Congressman Steny Hoyer">SENTINEL POLS: Everything you need to know about CD6 candidate Levi&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5ae506936be7d" data-td_block_id="td_uid_1_5ae506936be7d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5ae506936be7d" data-td_block_id="td_uid_1_5ae506936be7d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264971"><a href="https://www.sentinelcolorado.com/metro/nation-and-world/">Colorado, Nation &#038; World</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-272636"><a href="https://www.sentinelcolorado.com/sentinel-voter-guide-2018/">Sentinel Voter Guide 2018</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264968"><a href="https://www.sentinelcolorado.com/metro/your-news/">Your News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-264961"><a href="https://www.sentinelcolorado.com/sentinel-biz/">Sentinel Biz</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5ae506936f3fe_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_2_5ae506936f3fe"><script>var block_td_uid_2_5ae506936f3fe=new tdBlock();block_td_uid_2_5ae506936f3fe.id="td_uid_2_5ae506936f3fe";block_td_uid_2_5ae506936f3fe.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31508","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5ae506936f3fe_rand","tdc_css_class":"td_uid_2_5ae506936f3fe_rand","tdc_css_class_style":"td_uid_2_5ae506936f3fe_rand_style"}';block_td_uid_2_5ae506936f3fe.td_column_number="3";block_td_uid_2_5ae506936f3fe.block_type="td_block_mega_menu";block_td_uid_2_5ae506936f3fe.post_count="5";block_td_uid_2_5ae506936f3fe.found_posts="88";block_td_uid_2_5ae506936f3fe.header_color="";block_td_uid_2_5ae506936f3fe.ajax_pagination_infinite_stop="";block_td_uid_2_5ae506936f3fe.max_num_pages="18";tdBlocksArray.push(block_td_uid_2_5ae506936f3fe);</script><div id=td_uid_2_5ae506936f3fe class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/us-economic-growth-slowed-to-2-3-percent-pace-in-q1/" rel="bookmark" class="td-image-wrap" title="US economic growth slowed to 2.3 percent pace in Q1"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27090154/AP18109740892213-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27090154/AP18109740892213-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27090154/AP18109740892213-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27090154/AP18109740892213-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="US economic growth slowed to 2.3 percent pace in Q1" /></a></div> </div>
<div class="item-details">
 <h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/us-economic-growth-slowed-to-2-3-percent-pace-in-q1/" rel="bookmark" title="US economic growth slowed to 2.3 percent pace in Q1">US economic growth slowed to 2.3 percent pace in Q1</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/get-into-my-car-amazon-begins-delivery-to-vehicles/" rel="bookmark" class="td-image-wrap" title="Get Into My Car &#8230; Amazon begins delivery to vehicles"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24090230/AP18114406533706-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24090230/AP18114406533706-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24090230/AP18114406533706-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24090230/AP18114406533706-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Get Into My Car &#8230; Amazon begins delivery to vehicles" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/get-into-my-car-amazon-begins-delivery-to-vehicles/" rel="bookmark" title="Get Into My Car &#8230; Amazon begins delivery to vehicles">Get Into My Car &#8230; Amazon begins delivery to vehicles</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/wells-fargo-to-pay-1b-for-mortgage-auto-lending-abuses/" rel="bookmark" class="td-image-wrap" title="Wells Fargo to pay $1B for mortgage, auto lending abuses"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/20092935/AP18109803073641-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/20092935/AP18109803073641-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/20092935/AP18109803073641-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/20092935/AP18109803073641-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Wells Fargo to pay $1B for mortgage, auto lending abuses" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/wells-fargo-to-pay-1b-for-mortgage-auto-lending-abuses/" rel="bookmark" title="Wells Fargo to pay $1B for mortgage, auto lending abuses">Wells Fargo to pay $1B for mortgage, auto lending abuses</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/when-to-ignore-credit-card-advice/" rel="bookmark" class="td-image-wrap" title="When to ignore credit card advice"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19091126/AP18103491630689-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19091126/AP18103491630689-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19091126/AP18103491630689-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19091126/AP18103491630689-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="When to ignore credit card advice" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/when-to-ignore-credit-card-advice/" rel="bookmark" title="When to ignore credit card advice">When to ignore credit card advice</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/immigrant-drivers-bill-advances-to-aid-colorado-farm-labor/" rel="bookmark" class="td-image-wrap" title="Immigrant driver&#8217;s bill advances to aid Colorado farm labor"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19071316/AP18108787107425-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19071316/AP18108787107425-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19071316/AP18108787107425-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/19071316/AP18108787107425-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Immigrant driver&#8217;s bill advances to aid Colorado farm labor" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/immigrant-drivers-bill-advances-to-aid-colorado-farm-labor/" rel="bookmark" title="Immigrant driver&#8217;s bill advances to aid Colorado farm labor">Immigrant driver&#8217;s bill advances to aid Colorado farm labor</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5ae506936f3fe" data-td_block_id="td_uid_2_5ae506936f3fe"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5ae506936f3fe" data-td_block_id="td_uid_2_5ae506936f3fe"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-265088"><a href="https://www.sentinelcolorado.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5ae50693732fd_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_3_5ae50693732fd"><script>var block_td_uid_3_5ae50693732fd=new tdBlock();block_td_uid_3_5ae50693732fd.id="td_uid_3_5ae50693732fd";block_td_uid_3_5ae50693732fd.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31516","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_3_5ae50693732fd_rand","tdc_css_class":"td_uid_3_5ae50693732fd_rand","tdc_css_class_style":"td_uid_3_5ae50693732fd_rand_style"}';block_td_uid_3_5ae50693732fd.td_column_number="3";block_td_uid_3_5ae50693732fd.block_type="td_block_mega_menu";block_td_uid_3_5ae50693732fd.post_count="5";block_td_uid_3_5ae50693732fd.found_posts="79";block_td_uid_3_5ae50693732fd.header_color="";block_td_uid_3_5ae50693732fd.ajax_pagination_infinite_stop="";block_td_uid_3_5ae50693732fd.max_num_pages="16";tdBlocksArray.push(block_td_uid_3_5ae50693732fd);</script><div id=td_uid_3_5ae50693732fd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/quidnunc-aurora-should-join-the-national-league-of/" rel="bookmark" class="td-image-wrap" title="QUIDNUNC: Aurora should join the National League of Witty"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="QUIDNUNC: Aurora should join the National League of Witty" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/quidnunc-aurora-should-join-the-national-league-of/" rel="bookmark" title="QUIDNUNC: Aurora should join the National League of Witty">QUIDNUNC: Aurora should join the National League of Witty</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/toon-in-friday-152/" rel="bookmark" class="td-image-wrap" title="Toon in Friday"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074249/209796_600-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074249/209796_600-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074249/209796_600-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074249/209796_600-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Toon in Friday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/toon-in-friday-152/" rel="bookmark" title="Toon in Friday">Toon in Friday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridoped/anita-walker-its-time-to-help-working-parents-better-afford-quality-child-care/" rel="bookmark" class="td-image-wrap" title="ANITA WALKER: It’s time to help working parents better afford quality child care"><img width="218" height="145" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016.jpg 1250w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-610x407.jpg 610w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-1024x682.jpg 1024w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614153448/AS.NewLegacyCharterSchool3707.06072016-320x213.jpg 320w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="ANITA WALKER: It’s time to help working parents better afford quality child care" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridoped/anita-walker-its-time-to-help-working-parents-better-afford-quality-child-care/" rel="bookmark" title="ANITA WALKER: It’s time to help working parents better afford quality child care">ANITA WALKER: It’s time to help working parents better afford quality&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridoped/toon-in-thursday-150/" rel="bookmark" class="td-image-wrap" title="Toon in Thursday"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25212611/209746_600-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25212611/209746_600-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25212611/209746_600-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25212611/209746_600-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Toon in Thursday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridoped/toon-in-thursday-150/" rel="bookmark" title="Toon in Thursday">Toon in Thursday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/perry-relieve-colorado-senate-republicans-of-their-chronic-homophobia-or-their-jobs/" rel="bookmark" class="td-image-wrap" title="PERRY: Help state Senate GOP struggling with their fear of gay Coloradans"><img width="216" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614151609/Gay-Marriage-One-Year_Perr-6.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614151609/Gay-Marriage-One-Year_Perr-6.jpg 512w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614151609/Gay-Marriage-One-Year_Perr-6-256x178.jpg 256w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170614151609/Gay-Marriage-One-Year_Perr-6-320x223.jpg 320w" sizes="(max-width: 216px) 100vw, 216px" alt="" title="PERRY: Help state Senate GOP struggling with their fear of gay Coloradans" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/perry-relieve-colorado-senate-republicans-of-their-chronic-homophobia-or-their-jobs/" rel="bookmark" title="PERRY: Help state Senate GOP struggling with their fear of gay Coloradans">PERRY: Help state Senate GOP struggling with their fear of gay&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5ae50693732fd" data-td_block_id="td_uid_3_5ae50693732fd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5ae50693732fd" data-td_block_id="td_uid_3_5ae50693732fd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-264978"><a href="https://www.sentinelcolorado.com/colorado-table/">Colorado Table</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5ae5069377c2e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_4_5ae5069377c2e"><script>var block_td_uid_4_5ae5069377c2e=new tdBlock();block_td_uid_4_5ae5069377c2e.id="td_uid_4_5ae5069377c2e";block_td_uid_4_5ae5069377c2e.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31511","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_4_5ae5069377c2e_rand","tdc_css_class":"td_uid_4_5ae5069377c2e_rand","tdc_css_class_style":"td_uid_4_5ae5069377c2e_rand_style"}';block_td_uid_4_5ae5069377c2e.td_column_number="3";block_td_uid_4_5ae5069377c2e.block_type="td_block_mega_menu";block_td_uid_4_5ae5069377c2e.post_count="5";block_td_uid_4_5ae5069377c2e.found_posts="36";block_td_uid_4_5ae5069377c2e.header_color="";block_td_uid_4_5ae5069377c2e.ajax_pagination_infinite_stop="";block_td_uid_4_5ae5069377c2e.max_num_pages="8";tdBlocksArray.push(block_td_uid_4_5ae5069377c2e);</script><div id=td_uid_4_5ae5069377c2e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/cooking-on-deadline-greek-roasted-chicken-breasts/" rel="bookmark" class="td-image-wrap" title="COOKING ON DEADLINE: Greek Roasted Chicken Breasts"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24085552/AP18079753059140-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24085552/AP18079753059140-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24085552/AP18079753059140-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/24085552/AP18079753059140-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="COOKING ON DEADLINE: Greek Roasted Chicken Breasts" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/cooking-on-deadline-greek-roasted-chicken-breasts/" rel="bookmark" title="COOKING ON DEADLINE: Greek Roasted Chicken Breasts">COOKING ON DEADLINE: Greek Roasted Chicken Breasts</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/spatzle-primavera-is-made-with-vegetables-cream-and-cheese/" rel="bookmark" class="td-image-wrap" title="Spatzle Primavera is made with vegetables, cream and cheese"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/23085009/AP18101686913604-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/23085009/AP18101686913604-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/23085009/AP18101686913604-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/23085009/AP18101686913604-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Spatzle Primavera is made with vegetables, cream and cheese" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/spatzle-primavera-is-made-with-vegetables-cream-and-cheese/" rel="bookmark" title="Spatzle Primavera is made with vegetables, cream and cheese">Spatzle Primavera is made with vegetables, cream and cheese</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/spicy-chorizo-can-bring-people-together/" rel="bookmark" class="td-image-wrap" title="Spicy chorizo can bring people together"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/21093440/AP18108798559928-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/21093440/AP18108798559928-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/21093440/AP18108798559928-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/21093440/AP18108798559928-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Spicy chorizo can bring people together" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/spicy-chorizo-can-bring-people-together/" rel="bookmark" title="Spicy chorizo can bring people together">Spicy chorizo can bring people together</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/cooking-on-deadline-fattoush/" rel="bookmark" class="td-image-wrap" title="COOKING ON DEADLINE: Fattoush"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/18084845/AP18079751511169-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/18084845/AP18079751511169-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/18084845/AP18079751511169-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/18084845/AP18079751511169-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="COOKING ON DEADLINE: Fattoush" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/cooking-on-deadline-fattoush/" rel="bookmark" title="COOKING ON DEADLINE: Fattoush">COOKING ON DEADLINE: Fattoush</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/brussels-sprouts-push-nutrition-in-a-classic-caesar-salad/" rel="bookmark" class="td-image-wrap" title="Brussels sprouts push nutrition in a classic Caesar salad"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/14115222/AP180896318574201-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/14115222/AP180896318574201-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/14115222/AP180896318574201-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/14115222/AP180896318574201-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Brussels sprouts push nutrition in a classic Caesar salad" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/brussels-sprouts-push-nutrition-in-a-classic-caesar-salad/" rel="bookmark" title="Brussels sprouts push nutrition in a classic Caesar salad">Brussels sprouts push nutrition in a classic Caesar salad</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5ae5069377c2e" data-td_block_id="td_uid_4_5ae5069377c2e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_4_5ae5069377c2e" data-td_block_id="td_uid_4_5ae5069377c2e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-264966"><a href="https://www.sentinelcolorado.com/sentinel-magazine/">The Magazine</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_5_5ae506937c327_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_5_5ae506937c327"><script>var block_td_uid_5_5ae506937c327=new tdBlock();block_td_uid_5_5ae506937c327.id="td_uid_5_5ae506937c327";block_td_uid_5_5ae506937c327.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31510","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_5_5ae506937c327_rand","tdc_css_class":"td_uid_5_5ae506937c327_rand","tdc_css_class_style":"td_uid_5_5ae506937c327_rand_style"}';block_td_uid_5_5ae506937c327.td_column_number="3";block_td_uid_5_5ae506937c327.block_type="td_block_mega_menu";block_td_uid_5_5ae506937c327.post_count="5";block_td_uid_5_5ae506937c327.found_posts="53";block_td_uid_5_5ae506937c327.header_color="";block_td_uid_5_5ae506937c327.ajax_pagination_infinite_stop="";block_td_uid_5_5ae506937c327.max_num_pages="11";tdBlocksArray.push(block_td_uid_5_5ae506937c327);</script><div id=td_uid_5_5ae506937c327 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridmagazine/new-avengers-film-nabs-4th-biggest-preview-gross-ever/" rel="bookmark" class="td-image-wrap" title="New &#8216;Avengers&#8217; film nabs 4th biggest preview gross ever"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27161928/AP18113831833440-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27161928/AP18113831833440-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27161928/AP18113831833440-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27161928/AP18113831833440-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="New &#8216;Avengers&#8217; film nabs 4th biggest preview gross ever" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridmagazine/new-avengers-film-nabs-4th-biggest-preview-gross-ever/" rel="bookmark" title="New &#8216;Avengers&#8217; film nabs 4th biggest preview gross ever">New &#8216;Avengers&#8217; film nabs 4th biggest preview gross ever</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/abba-says-it-records-2-songs-first-new-material-in-35-years/" rel="bookmark" class="td-image-wrap" title="ABBA says it records 2 songs, first new material in 35 years"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27091938/AP18117445603529-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27091938/AP18117445603529-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27091938/AP18117445603529-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27091938/AP18117445603529-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="ABBA says it records 2 songs, first new material in 35 years" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/abba-says-it-records-2-songs-first-new-material-in-35-years/" rel="bookmark" title="ABBA says it records 2 songs, first new material in 35 years">ABBA says it records 2 songs, first new material in 35&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/netflix-documentary-explores-rfks-legacy-50-years-later/" rel="bookmark" class="td-image-wrap" title="Netflix documentary explores RFK&#8217;s legacy 50 years later"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26090901/AP18113799965185-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26090901/AP18113799965185-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26090901/AP18113799965185-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26090901/AP18113799965185-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Netflix documentary explores RFK&#8217;s legacy 50 years later" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/netflix-documentary-explores-rfks-legacy-50-years-later/" rel="bookmark" title="Netflix documentary explores RFK&#8217;s legacy 50 years later">Netflix documentary explores RFK&#8217;s legacy 50 years later</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/summer-movie-preview-deadpool-2-is-about-kindness-truly/" rel="bookmark" class="td-image-wrap" title="Summer Movie Preview: &#8216;Deadpool 2&#8217; is about kindness (truly)"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25091144/AP18114788917667-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25091144/AP18114788917667-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25091144/AP18114788917667-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25091144/AP18114788917667-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Summer Movie Preview: &#8216;Deadpool 2&#8217; is about kindness (truly)" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/summer-movie-preview-deadpool-2-is-about-kindness-truly/" rel="bookmark" title="Summer Movie Preview: &#8216;Deadpool 2&#8217; is about kindness (truly)">Summer Movie Preview: &#8216;Deadpool 2&#8217; is about kindness (truly)</a></h3> </div>
 </div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/a-star-is-born-steals-show-in-starry-warner-bros-slate/" rel="bookmark" class="td-image-wrap" title="&#8216;A Star is Born&#8217; steals show in starry Warner Bros. slate"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25090305/AP18114808504474-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25090305/AP18114808504474-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25090305/AP18114808504474-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25090305/AP18114808504474-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;A Star is Born&#8217; steals show in starry Warner Bros. slate" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/a-star-is-born-steals-show-in-starry-warner-bros-slate/" rel="bookmark" title="&#8216;A Star is Born&#8217; steals show in starry Warner Bros. slate">&#8216;A Star is Born&#8217; steals show in starry Warner Bros. slate</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5ae506937c327" data-td_block_id="td_uid_5_5ae506937c327"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_5_5ae506937c327" data-td_block_id="td_uid_5_5ae506937c327"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-mega-menu menu-item-264962"><a href="https://www.sentinelcolorado.com/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_5ae5069381891_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_6_5ae5069381891"><script>var block_td_uid_6_5ae5069381891=new tdBlock();block_td_uid_6_5ae5069381891.id="td_uid_6_5ae5069381891";block_td_uid_6_5ae5069381891.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"31513","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_6_5ae5069381891_rand","tdc_css_class":"td_uid_6_5ae5069381891_rand","tdc_css_class_style":"td_uid_6_5ae5069381891_rand_style"}';block_td_uid_6_5ae5069381891.td_column_number="3";block_td_uid_6_5ae5069381891.block_type="td_block_mega_menu";block_td_uid_6_5ae5069381891.post_count="5";block_td_uid_6_5ae5069381891.found_posts="135";block_td_uid_6_5ae5069381891.header_color="";block_td_uid_6_5ae5069381891.ajax_pagination_infinite_stop="";block_td_uid_6_5ae5069381891.max_num_pages="27";tdBlocksArray.push(block_td_uid_6_5ae5069381891);</script><div id=td_uid_6_5ae5069381891 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/pro/rockies/rockies-senzatela-replaces-injured-starter-hits-rbi-double/" rel="bookmark" class="td-image-wrap" title="Rockies&#8217; Senzatela replaces injured starter, hits RBI double"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28094627/AP18118113587747-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28094627/AP18118113587747-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28094627/AP18118113587747-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28094627/AP18118113587747-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Rockies&#8217; Senzatela replaces injured starter, hits RBI double" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/pro/rockies/rockies-senzatela-replaces-injured-starter-hits-rbi-double/" rel="bookmark" title="Rockies&#8217; Senzatela replaces injured starter, hits RBI double">Rockies&#8217; Senzatela replaces injured starter, hits RBI double</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/1gridsports/espn-cowboys-witten-retiring-after-15-seasons-for-mnf/" rel="bookmark" class="td-image-wrap" title="ESPN: Cowboys&#8217; Witten retiring after 15 seasons for &#8216;MNF&#8217;"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27163349/AP18117714834487-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27163349/AP18117714834487-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27163349/AP18117714834487-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27163349/AP18117714834487-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="ESPN: Cowboys&#8217; Witten retiring after 15 seasons for &#8216;MNF&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/1gridsports/espn-cowboys-witten-retiring-after-15-seasons-for-mnf/" rel="bookmark" title="ESPN: Cowboys&#8217; Witten retiring after 15 seasons for &#8216;MNF&#8217;">ESPN: Cowboys&#8217; Witten retiring after 15 seasons for &#8216;MNF&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/pro/broncos/broncos-grab-bradley-chubb-in-nfl-draft-to-team-with-von-miller/" rel="bookmark" class="td-image-wrap" title="Broncos grab Bradley Chubb in NFL draft to team with Von Miller"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26202842/AP18117033252805-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26202842/AP18117033252805-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26202842/AP18117033252805-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/26202842/AP18117033252805-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Broncos grab Bradley Chubb in NFL draft to team with Von Miller" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/pro/broncos/broncos-grab-bradley-chubb-in-nfl-draft-to-team-with-von-miller/" rel="bookmark" title="Broncos grab Bradley Chubb in NFL draft to team with Von Miller">Broncos grab Bradley Chubb in NFL draft to team with Von&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/sports/pro/rockies/gray-strikes-out-11-to-help-rockies-beat-padres-5-2-and-finish-series/" rel="bookmark" class="td-image-wrap" title="Gray strikes out 11 to help Rockies beat Padres 5-2 and finish series"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25230901/AP18115705028418-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25230901/AP18115705028418-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25230901/AP18115705028418-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25230901/AP18115705028418-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Gray strikes out 11 to help Rockies beat Padres 5-2 and finish series" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/sports/pro/rockies/gray-strikes-out-11-to-help-rockies-beat-padres-5-2-and-finish-series/" rel="bookmark" title="Gray strikes out 11 to help Rockies beat Padres 5-2 and finish series">Gray strikes out 11 to help Rockies beat Padres 5-2 and&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-meta-info-hide td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/uncategorized/apnewsbreak-hoops-panel-says-ban-cheats-end-1-and-done/" rel="bookmark" class="td-image-wrap" title="APNewsBreak: Hoops panel says ban cheats, end 1-and-done"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25093802/AP18115470373058-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25093802/AP18115470373058-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25093802/AP18115470373058-474x324.jpg 474w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/25093802/AP18115470373058-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="APNewsBreak: Hoops panel says ban cheats, end 1-and-done" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/uncategorized/apnewsbreak-hoops-panel-says-ban-cheats-end-1-and-done/" rel="bookmark" title="APNewsBreak: Hoops panel says ban cheats, end 1-and-done">APNewsBreak: Hoops panel says ban cheats, end 1-and-done</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5ae5069381891" data-td_block_id="td_uid_6_5ae5069381891"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_5ae5069381891" data-td_block_id="td_uid_6_5ae5069381891"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270582"><a href="https://www.sentinelcolorado.com/sports/a-town-all-stars/">A-Town All-Stars</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264965"><a href="https://www.sentinelcolorado.com/sports/sentinel-preps/">Sentinel Preps</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-264973"><a href="https://www.sentinelcolorado.com/contact-us/">Contact Us</a></li>
</ul></div></div>
<div class="header-search-wrap"> 
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.sentinelcolorado.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  td_uid_7_5ae50693860be_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-3'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-3');});</script>
</div>
</div></div>
</div> </div>
</div>
</div>
</div><div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-5 ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.sentinelcolorado.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in 0Trending" class="entry-crumb" href="https://www.sentinelcolorado.com/category/0trending/">0Trending</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry...</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-281003" class="post-281003 post type-post status-publish format-standard has-post-thumbnail hentry category-0trending category-1gridhome category-1gridmetro category-colorado-capital category-education category-metro category-state-and-region" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/state-and-region/">State and Region</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/state-and-region/colorado-capital/">Colorado Capitol</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/metro/">Metro</a></li><li class="entry-category"><a href="https://www.sentinelcolorado.com/category/news/metro/education/">Education</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="">COLLEEN SLEVIN, Associated Press</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2018-04-28T09:22:36+00:00">April 28, 2018</time></span> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-281003">23</span></div> </div>
</header>
</div>
<div class="td-post-content">
<div class="at-above-post addthis_tool" data-url="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/"></div>
<style type="text/css">#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item1{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item2{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item3{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item4{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item5{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item6{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item7{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-80x60.jpg) 0 0 no-repeat}#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-item8{background:url(https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-80x60.jpg) 0 0 no-repeat}</style>
<div id="td_uid_8_5ae50693871c0" class="td-gallery td-slide-on-2-columns">
<div class="post_td_gallery">
<div class="td-gallery-slide-top">
<div class="td-gallery-title"></div>
<div class="td-gallery-controls-wrapper">
<div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 8</div>
<div class="td-gallery-slide-prev-next-but">
<i class="td-icon-left doubleSliderPrevButton"></i>
<i class="td-icon-right doubleSliderNextButton"></i>
</div>
</div>
</div>
<div class="td-doubleSlider-1 ">
<div class="td-slider">
<div class="td-slide-item td-item1">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644.jpg" title="Teachers with placards" data-caption="Teachers carry placards as they march during a rally Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-523x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-523x420.jpg 523w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-222x178.jpg 222w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-768x617.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-448x360.jpg 448w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644-696x559.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080215/AP18117643895644.jpg 1024w" sizes="(max-width: 523px) 100vw, 523px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Teachers carry placards as they march during a rally Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item2">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792.jpg" title="Colorado teachers march" data-caption="Teachers march across Broadway during a rally Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-624x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-624x420.jpg 624w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-265x178.jpg 265w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-768x517.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-535x360.jpg 535w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792-696x468.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080230/AP18117652380792.jpg 1024w" sizes="(max-width: 624px) 100vw, 624px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Teachers march across Broadway during a rally Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item3">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg" title="Colorado teachers" data-caption="Teachers march during a rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-630x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-630x420.jpg 630w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065-696x464.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg 1024w" sizes="(max-width: 630px) 100vw, 630px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Teachers march during a rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (AP Photo/David Zalubowski)</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item4">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583.jpg" title="Teacher Protests" data-caption="Summit High School social studies teacher Jotwan Daniels, in front, marches during a teacher rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (Hugh Carey/Summit Daily News via AP)" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-580x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-580x420.jpg 580w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-246x178.jpg 246w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-768x557.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-497x360.jpg 497w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-324x235.jpg 324w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583-696x504.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080302/AP18117680415583.jpg 1024w" sizes="(max-width: 580px) 100vw, 580px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Summit High School social studies teacher Jotwan Daniels, in front, marches during a teacher rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (Hugh Carey/Summit Daily News via AP)</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item5">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333.jpg" title="Teacher Protests" data-caption="Teachers gather for rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (Hugh Carey/Summit Daily News via AP)" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-631x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-631x420.jpg 631w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-541x360.jpg 541w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333-696x464.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080317/AP18117680500333.jpg 1024w" sizes="(max-width: 631px) 100vw, 631px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Teachers gather for rally, Friday, April 27, 2018, in Denver. More than 10,000 teachers from more than 20 districts scattered across Colorado are demonstrating as part of a burgeoning teacher uprising from the East to the interior West that is demanding more tax dollars be spent in public schools. (Hugh Carey/Summit Daily News via AP)</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item6">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6.jpg" title="as.art_.teacherrally.vlh-6" data-caption="Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-630x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-630x420.jpg 630w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6-696x464.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173151/as.art_.teacherrally.vlh-6.jpg 800w" sizes="(max-width: 630px) 100vw, 630px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item7">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2.jpg" title="as.art_.teacherrally.vlh-2" data-caption="Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-630x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-630x420.jpg 630w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2-696x464.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173136/as.art_.teacherrally.vlh-2.jpg 800w" sizes="(max-width: 630px) 100vw, 630px" alt="">
</a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel</div></figcaption>
</figure>
</div>
<div class="td-slide-item td-item8">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1.jpg" title="as.art_.teacherrally.vlh-1" data-caption="Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel" data-description="">
<img src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-630x420.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-630x420.jpg 630w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1-696x464.jpg 696w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28173122/as.art_.teacherrally.vlh-1.jpg 800w" sizes="(max-width: 630px) 100vw, 630px" alt="">
 </a>
<figcaption class="td-slide-caption td-gallery-slide-content"><div class="td-gallery-slide-copywrite">Thousands of Colorado teachers gathered outside the state capitol demanding more funding and better wages after multiple county walk-outs occured on April 27. Photo by Veronica L Holyfield/The Sentinel</div></figcaption>
</figure>
</div>
</div>
</div>
<div class="td-doubleSlider-2">
<div class="td-slider">
<div class="td-button td-item1">
<div class="td-border"></div>
</div>
<div class="td-button td-item2">
<div class="td-border"></div>
</div>
<div class="td-button td-item3">
<div class="td-border"></div>
</div>
<div class="td-button td-item4">
<div class="td-border"></div>
</div>
<div class="td-button td-item5">
<div class="td-border"></div>
</div>
<div class="td-button td-item6">
<div class="td-border"></div>
</div>
<div class="td-button td-item7">
<div class="td-border"></div>
</div>
<div class="td-button td-item8">
<div class="td-border"></div>
</div>
</div>
</div>
</div>
</div>
<p><strong>DENVER</strong> | Thousands of teachers protested at the Colorado state Capitol for increased school funding Friday, winning support but so far no new action from lawmakers wrapping up their work for the year.</p>
<p>The latest gathering of teachers — the largest of three this month — led to classes being cancelled in about two dozen districts, including Denver, APS and Cherry Creek. The tone was more festive, with a jazz band warming up the crowd by leading them in songs like &#8220;Marching on to Freedom Land.&#8221; Teachers danced along, while others kept some beach balls bouncing over the crowd at Civic Center Park before marching over to the Capitol.</p>
<p>Schools in Aurora Public Schools and Cherry Creek were closed Friday.</p>
<p>Gov. John Hickenlooper briefly addressed them, promising that he and Lt. Gov. Donna Lynne, who is running for the Democratic nomination to replace him, would push to restore the approximately $1 billion shifted from education to the rest of the state&#8217;s budget during the recession. During his speech, some teachers shouted over the term-limited governor by saying things like &#8220;We want more&#8221; and &#8220;Action not words&#8221; but many applauded him at the end.</p>
<p>The state&#8217;s largest teachers union and organizer of the rallies, the Colorado Education Association, has endorsed former state treasurer Cary Kennedy for the Democratic nomination. She drew cheers when she called for a change to the state&#8217;s strict tax-and-spending limits.</p>
<p>Some Democratic state lawmakers also joined teachers on the steps of the Colorado Capitol for an afternoon rally where National Education Association vice president Becky Pringle scolded lawmakers for giving tax breaks to corporations but &#8220;leaving our babies to beg for whatever&#8217;s left&#8221; for education. She called on teachers to keep fighting and to restore education funding.</p>
<p>Denver teacher Gerardo Munoz urged teachers not to let the rally be the end of their activism, telling them to speak at school board meetings, call their lawmakers and write letters to the editor.</p>
<p>The Colorado Education Association is also asking its members to help get an initiative that would raise taxes on people with taxable incomes over $125,000 to provide more money for education on November&#8217;s ballot.</p>
<p>Lawmakers have agreed to give schools their largest budget increase since the recession but the teachers&#8217; union wants them to repay the rest of what they say was wrongly taken from schools during the recession over the next four years. Lawmakers, who are not able to raise taxes on their own under the Taxpayers Bill of Rights, say they have done all they can with the money available.</p>
<p>Heidi Scolari, a middle school art school teacher in Eaton, made a point about the efforts some school districts go through to raise extra money by marching with a yard sign once used for her small rural district&#8217;s annual mattress sale fundraiser. One side pointed out that Bill Gates didn&#8217;t have to sell mattress to pay for his education; On the back it said &#8220;It&#8217;s time, Colorado.&#8221;</p>
<p>Even if the demonstrations don&#8217;t lead to immediate changes, she said there was still a reason to speak out now.</p>
<p>&#8220;To make our voices heard and let them know we&#8217;re sick of it,&#8221; she said of the state&#8217;s education funding.</p>
<div class="at-below-post addthis_tool" data-url="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/"></div><div class="at-below-post-recommended addthis_tool"></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.sentinelcolorado.com/1gridcontlworld/white-house-records-dispute-allegations-against-jackson/">White House: Records dispute allegations against Jackson</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.sentinelcolorado.com/orecent-headlines/centennial-man-convicted-of-killing-estranged-wife-in-front-of-teen-son/">Centennial man convicted of killing estranged wife in front of teen son</a></div></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="">COLLEEN SLEVIN, Associated Press</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="COLLEEN SLEVIN, Associated Press"></span><meta itemprop="datePublished" content="2018-04-28T09:22:36+00:00"><meta itemprop="dateModified" content="2018-04-28T17:32:55+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.sentinelcolorado.com/1gridhome/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/03/07170641/Website-Flag-Vector-03.18.jpg"></span><meta itemprop="name" content="Sentinel Colorado"></span><meta itemprop="headline " content="Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/28080246/AP18117658215065.jpg"><meta itemprop="width" content="1024"><meta itemprop="height" content="683"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_10_5ae506939086a_rand td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_10_5ae506939086a"><script>var block_td_uid_10_5ae506939086a=new tdBlock();block_td_uid_10_5ae506939086a.id="td_uid_10_5ae506939086a";block_td_uid_10_5ae506939086a.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_10_5ae506939086a_rand","td_column_number":3,"live_filter_cur_post_id":281003,"live_filter_cur_post_author":"3","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_10_5ae506939086a_rand","tdc_css_class_style":"td_uid_10_5ae506939086a_rand_style"}';block_td_uid_10_5ae506939086a.td_column_number="3";block_td_uid_10_5ae506939086a.block_type="td_block_related_posts";block_td_uid_10_5ae506939086a.post_count="3";block_td_uid_10_5ae506939086a.found_posts="13467";block_td_uid_10_5ae506939086a.header_color="";block_td_uid_10_5ae506939086a.ajax_pagination_infinite_stop="";block_td_uid_10_5ae506939086a.max_num_pages="4489";tdBlocksArray.push(block_td_uid_10_5ae506939086a);</script><h4 class="td-related-title td-block-title"><a id="td_uid_11_5ae50693ac20e" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_10_5ae506939086a" href="#">RELATED ARTICLES</a><a id="td_uid_12_5ae50693ac27e" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_10_5ae506939086a" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_10_5ae506939086a class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/orecent-headlines/centennial-man-convicted-of-killing-estranged-wife-in-front-of-teen-son/" rel="bookmark" class="td-image-wrap" title="Centennial man convicted of killing estranged wife in front of teen son"><img width="194" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice.jpg 440w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice-230x178.jpg 230w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180226194945/SentinelBadgePolice-320x248.jpg 320w" sizes="(max-width: 194px) 100vw, 194px" alt="" title="Centennial man convicted of killing estranged wife in front of teen son" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/orecent-headlines/centennial-man-convicted-of-killing-estranged-wife-in-front-of-teen-son/" rel="bookmark" title="Centennial man convicted of killing estranged wife in front of teen son">Centennial man convicted of killing estranged wife in front of teen son</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/coffman-keeps-touting-national-debt-as-high-priority/" rel="bookmark" class="td-image-wrap" title="Tillemann likens Coffman to a &#8216;deadbeat dad&#8217; for &#8216;hypocrisy&#8217; on national debt"><img width="218" height="145" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_.jpg 1250w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-267x178.jpg 267w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-768x512.jpg 768w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-540x360.jpg 540w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-610x407.jpg 610w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-1024x682.jpg 1024w, https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20170412211724/AS.Coffman0978.web_-320x213.jpg 320w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Tillemann likens Coffman to a &#8216;deadbeat dad&#8217; for &#8216;hypocrisy&#8217; on national debt" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/coffman-keeps-touting-national-debt-as-high-priority/" rel="bookmark" title="Tillemann likens Coffman to a &#8216;deadbeat dad&#8217; for &#8216;hypocrisy&#8217; on national debt">Tillemann likens Coffman to a &#8216;deadbeat dad&#8217; for &#8216;hypocrisy&#8217; on national debt</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.sentinelcolorado.com/0trending/quidnunc-aurora-should-join-the-national-league-of/" rel="bookmark" class="td-image-wrap" title="QUIDNUNC: Aurora should join the National League of Witty"><img width="218" height="150" class="entry-thumb" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-218x150.jpg" srcset="https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-218x150.jpg 218w, https://s3-us-west-2.amazonaws.com/aurorasentinel/2018/04/27074759/oabJWI0J_400x4001-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="QUIDNUNC: Aurora should join the National League of Witty" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.sentinelcolorado.com/0trending/quidnunc-aurora-should-join-the-national-league-of/" rel="bookmark" title="QUIDNUNC: Aurora should join the National League of Witty">QUIDNUNC: Aurora should join the National League of Witty</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_10_5ae506939086a" data-td_block_id="td_uid_10_5ae506939086a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_10_5ae506939086a" data-td_block_id="td_uid_10_5ae506939086a"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div id="disqus_thread"></div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
 <div class="td-ss-main-sidebar">
<div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_13_5ae50693b43a4_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-4' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-4');});</script>
</div>
<br /><br />

<div id='div-gpt-ad-1520977200202-5' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-5');});</script>
</div>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_2  td_uid_14_5ae50693b460c_rand td_block_template_11"><div class="td-all-devices">

<div id='div-gpt-ad-1520977200202-6' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-6');});</script>
</div>
<br /><br />

<div id='div-gpt-ad-1520977200202-7' style='height:250px; width:300px;'>
<script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1520977200202-7');});</script>
</div>
</div></div> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap td-footer-template-4 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.sentinelcolorado.com/"><img class="td-retina-data" src="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer-e1520024990897.png" data-retina="https://s3-us-west-2.amazonaws.com/aurorasentinel/asuplads/20180301011122/sentinel-footer.png" alt="sentinel colorado" title="sentinel colorado" width="250" /></a></div><div class="footer-text-wrap"><div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#2b5c4e49464a585f4e596b4a5e5944594a584e455f42454e4705484446"><span class="__cf_email__" data-cfemail="710614131c1002051403311004031e031002141f05181f141d5f121e1c">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/theaurorasentinel/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/SentinelColorado/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.linkedin.com/company/1823430/" title="Linkedin">
<i class="td-icon-font td-icon-linkedin"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/AuroraSentinel" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://vimeo.com/sentinelcolorado" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span></div></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; 2018 Aurora Sentinel. All rights reserved. <a href="https://www.enviemedia.com" target="_blank">Colorado-proud website development</a> by Envie Media. </div>
</div>
</div>
</div>
</div>
<div style="display:none">
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script>window._popup_data={"ajaxurl":"https:\/\/www.sentinelcolorado.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/1gridhome\/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek\/"}};</script><script data-cfasync="false" type="text/javascript">if(window.addthis_product===undefined){window.addthis_product="wpwt";}if(window.wp_product_version===undefined){window.wp_product_version="wpwt-3.1.5";}if(window.wp_blog_version===undefined){window.wp_blog_version="4.9.5";}if(window.addthis_share===undefined){window.addthis_share={};}if(window.addthis_config===undefined){window.addthis_config={"data_track_clickback":true,"ui_atversion":"300"};}if(window.addthis_plugin_info===undefined){window.addthis_plugin_info={"info_status":"enabled","cms_name":"WordPress","plugin_name":"Website Tools by AddThis","plugin_version":"3.1.5","plugin_mode":"AddThis","anonymous_profile_id":"wp-3d2562241900bad7aa646a117c562340","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false};}
(function(){var first_load_interval_id=setInterval(function(){if(typeof window.addthis!=='undefined'){window.clearInterval(first_load_interval_id);if(typeof window.addthis_layers!=='undefined'&&Object.getOwnPropertyNames(window.addthis_layers).length>0){window.addthis.layers(window.addthis_layers);}
if(Array.isArray(window.addthis_layers_tools)){for(i=0;i<window.addthis_layers_tools.length;i++){window.addthis.layers(window.addthis_layers_tools[i]);}}}},1000)}());</script><script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=bfc51f3a494d884bb3b131714fa811cd#pubid=ra-5a8201abd5d150fc'></script>
<script type='text/javascript'>//<![CDATA[
var countVars={"disqusShortname":"aurorasentinel"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>//<![CDATA[
var embedVars={"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"281003 https:\/\/www.sentinelcolorado.com\/?p=281003","disqusShortname":"aurorasentinel","disqusTitle":"Thousands more teachers protest at Colorado Capitol, including those from APS, Cherry Creek","disqusUrl":"https:\/\/www.sentinelcolorado.com\/1gridhome\/thousands-more-teachers-protest-at-colorado-capitol-including-those-from-aps-cherry-creek\/","postId":"281003"};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201817'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Apraa'></script>
<script type='text/javascript'>//<![CDATA[
var WPGroHo={"my_hash":""};
//]]></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.7.3'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/comment-reply.min.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/js/wpmu-ui.3.min.js?ver=3.0.6'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-content/plugins/popover/js/public.min.js?ver=3.0.6'></script>
<script type='text/javascript' src='https://www.sentinelcolorado.com/wp-includes/js/wp-embed.min.js?ver=bfc51f3a494d884bb3b131714fa811cd'></script>

<script>jQuery().ready(function(){tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Aurora","api_location":"Aurora","api_language":"en","api_key":"eee53618725b7d26226f3b8b89b32780","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[11.5,52.7],"today_humidity":28,"today_wind_speed":[5.1,3.2],"today_min":[8,46.4],"today_max":[14,57.2],"today_clouds":1,"current_unit":1,"forecast":[{"timestamp":1524960000,"day_name":"Sun","day_temp":[16,61],"owm_day_index":0},{"timestamp":1525046400,"day_name":"Mon","day_temp":[24,75],"owm_day_index":8},{"timestamp":1525132800,"day_name":"Tue","day_temp":[29,84],"owm_day_index":16},{"timestamp":1525219200,"day_name":"Wed","day_temp":[27,81],"owm_day_index":24},{"timestamp":1525305600,"day_name":"Thu","day_temp":[19,66],"owm_day_index":32}]});});var td_uid_8_5ae50693871c0_nr_of_slides=8;jQuery(document).ready(function(){jQuery("#td_uid_8_5ae50693871c0 .td-slide-popup-gallery").magnificPopup({delegate:"a.slide-gallery-image-link",type:"image",tLoading:"Loading image #%curr%...",mainClass:"mfp-img-mobile",gallery:{enabled:true,navigateByImgClick:true,preload:[0,1],tCounter:'%curr% of %total%'},image:{tError:"<a href='%url%'>The image #%curr%</a> could not be loaded.",titleSrc:function(item){return item.el.attr("data-caption")+"<div>"+item.el.attr("data-description")+"<div>";}},zoom:{enabled:true,duration:300,opener:function(element){return element.find("img");}},callbacks:{change:function(){jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-1").iosSlider("goToSlide",this.currItem.index+1);}}});jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-1").iosSlider({scrollbar:true,snapToChildren:true,desktopClickDrag:true,infiniteSlider:true,responsiveSlides:true,navPrevSelector:jQuery("#td_uid_8_5ae50693871c0 .doubleSliderPrevButton"),navNextSelector:jQuery("#td_uid_8_5ae50693871c0 .doubleSliderNextButton"),scrollbarHeight:"2",scrollbarBorderRadius:"0",scrollbarOpacity:"0.5",onSliderResize:td_gallery_resize_update_vars_td_uid_8_5ae50693871c0,onSliderLoaded:doubleSlider2Load_td_uid_8_5ae50693871c0,onSlideChange:doubleSlider2Load_td_uid_8_5ae50693871c0,keyboardControls:true});jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-button").each(function(i){jQuery(this).bind("click",function(){jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-1").iosSlider("goToSlide",i+1);});});if(td_uid_8_5ae50693871c0_nr_of_slides>1){jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2").iosSlider({desktopClickDrag:true,snapToChildren:true,snapSlideCenter:true,infiniteSlider:true});}else{jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2").addClass("td_center_slide2");}
function doubleSlider2Load_td_uid_8_5ae50693871c0(args){jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2").iosSlider("goToSlide",args.currentSlideNumber);jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-button .td-border").css("border","3px solid #ffffff").css("opacity","0.5");jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-button").css("border","0");jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-2 .td-button:eq("+(args.currentSlideNumber-1)+") .td-border").css("border","3px solid #ffffff").css("opacity","1");td_gallery_write_current_slide_td_uid_8_5ae50693871c0(args.currentSlideNumber);}
function td_gallery_write_current_slide_td_uid_8_5ae50693871c0(slide_nr){jQuery("#td_uid_8_5ae50693871c0 .td-gallery-slide-item-focus").html(slide_nr);}
function td_gallery_resize_update_vars_td_uid_8_5ae50693871c0(args){if(tdDetect.isAndroid){setTimeout(function(){jQuery("#td_uid_8_5ae50693871c0 .td-doubleSlider-1").iosSlider("update");},1500);}}});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.sentinelcolorado.com/wp-content/themes/Newspaper/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.sentinelcolorado.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script>

<style>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</style>
<script type='text/javascript' src='https://stats.wp.com/e-201817.js' async='async' defer='defer'></script>
<script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:6.0',blog:'143429595',post:'281003',tz:'-6',srv:'www.sentinelcolorado.com'}]);_stq.push(['clickTrackerInit','143429595','281003']);</script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
<header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>(function(jQuery,undefined){jQuery(window).ready(function(){if('undefined'!==typeof tdcAdminIFrameUI){var $liveIframe=tdcAdminIFrameUI.getLiveIframe();if($liveIframe.length){$liveIframe.load(function(){$liveIframe.contents().find('body').append('<textarea class="tdw-css-writer-editor" style="display: none"></textarea>');});}}});})(jQuery);</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_5ae5069607e4c"></textarea>
<div id="td_live_css_uid_1_5ae5069607e4c" class="td-code-editor"></div>
<script>jQuery(window).load(function(){if('undefined'!==typeof tdLiveCssInject){tdLiveCssInject.init();var editor_textarea=jQuery('.td_live_css_uid_1_5ae5069607e4c');var languageTools=ace.require("ace/ext/language_tools");var tdcCompleter={getCompletions:function(editor,session,pos,prefix,callback){if(prefix.length===0){callback(null,[]);return}
if('undefined'!==typeof tdcAdminIFrameUI){var data={error:undefined,getShortcode:''};tdcIFrameData.getShortcodeFromData(data);if(!_.isUndefined(data.error)){tdcDebug.log(data.error);}
if(!_.isUndefined(data.getShortcode)){var regex=/el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,results=data.getShortcode.match(regex);var elClasses={};for(var i=0;i<results.length;i++){var currentClasses=results[i].replace('el_class="','').replace('"','').split(' ');for(var j=0;j<currentClasses.length;j++){if(_.isUndefined(elClasses[currentClasses[j]])){elClasses[currentClasses[j]]='';}}}
var arrElClasses=[];for(var prop in elClasses){arrElClasses.push(prop);}
callback(null,arrElClasses.map(function(item){return{name:item,value:item,meta:'in_page'}}));}}}};languageTools.addCompleter(tdcCompleter);window.editor=ace.edit("td_live_css_uid_1_5ae5069607e4c");window.editorChangeHandler=function(){window.onbeforeunload=function(){if(tdwState.lessWasEdited){return"You have attempted to leave this page. Are you sure?";}
return false;};var editorValue=editor.getSession().getValue();editor_textarea.val(editorValue);if('undefined'!==typeof tdcAdminIFrameUI){tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);tdcMain.setContentModified();}
tdLiveCssInject.less();};editor.getSession().setValue(editor_textarea.val());editor.getSession().on('change',editorChangeHandler);editor.setTheme("ace/theme/textmate");editor.setShowPrintMargin(false);editor.getSession().setMode("ace/mode/less");editor.setOptions({enableBasicAutocompletion:true,enableSnippets:true,enableLiveAutocompletion:false});}});</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
</body>
</html>


